Switching mail accounts to Local Folder doesn't set the new folders for sent etc.

RESOLVED DUPLICATE of bug 397429

Status

Thunderbird
Account Manager
--
minor
RESOLVED DUPLICATE of bug 397429
12 years ago
5 years ago

People

(Reporter: Daniel Fass, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPE 397429 here])

(Reporter)

Description

12 years ago
User-Agent:       Opera/9.00 (Windows NT 5.1; U; de)
Build Identifier: Version 1.5.0.5 (20060719)

I had 2 mail accounts and I merged them into the Local Folder. It worked fine with the inbox, but Thunderbird didn't change the "sent" location automaticly, so new send messages have been lost. I had to change the "sent" folder for my 2 mail accounts manually. 

It's the same with the folders "drafts" and "templates".

I think they should be changed automaticly to the Local Folder when switching multiple mail accounts to it, because it makes no sense not to change this. All sent messages are not stored in the sent folders of the mail accounts, but they are lost!

Reproducible: Always

Steps to Reproduce:
1.Remember to change the sent, drafts and templates folder manually after merging mail accounts with Local Folder
2.
3.

Comment 1

12 years ago
They are supposed to be changed automatically; bug 250212 implemented that shortly after account-deferral was implemented.  (Compare to bug 313047.)

I tried to reproduce your problem.  First, I deferred the test account to 
Local Folders, the settings under   Account Settings | Copies&Folders   were updated correctly.  (Well, sort of correctly.  The option for each folder was shown as:
   ( )   'Sent' on [Local Folders]
   (*)   'Sent on Local Folders'
The original setting had the first radio-button checked, and the dropdown 
showed the original account name.  Since that dropdown gets changed from "account name" to "Local Folders" I don't see the point of changing the radio selection.)

Then it occurred to me that there might be a problem with multiple identities.
I reset the test account to use its own folder list, and reset the folders to point to those.  (I checked, e.g., "'Sent' on [account]" -- the account name read "Local Folders" when I opened the dialog, but changed to <account name> when I clicked the radio button.)

Then I added a new identity (and checked that the folders were set correctly).

Then I deferred the account to the Global Inbox again -- and the folders were not changed on the original, default identity nor on the secondary one.

I tested using TB 3a1-0804, Win2K.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → Windows 2000
Version: unspecified → Trunk

Updated

9 years ago
Assignee: mscott → nobody

Updated

6 years ago
Blocks: 397429

Comment 2

6 years ago
I made this test:
- Account1, 2 identities, both having Drafts and Sent pointing to Account1.
- Account2, 2 identities, both having Drafts and Sent pointing to Account1.
- Now set Account1 to store to Global Inbox (Local folders).
Result:
All 4 identities had their Drafts and Sent set to Local Folders as far as I could see by visiting the account settings.
That looks correct to me.

So can anybody still reproduce this problem?
(Yes, Junk folder has this problem and will not be redirected automatically in this way. But that is being fixed in bug 536768 and bug 734034.)
Whiteboard: [CLOSEME 2012-09-01][DUPE 397429 here]

Comment 3

5 years ago
Resovled per whiteboard
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Whiteboard: [CLOSEME 2012-09-01][DUPE 397429 here] → [DUPE 397429 here]
Duplicate of bug: 397429
You need to log in before you can comment on or make changes to this bug.