background-position:bottom and background-repeat:no-repeat dont work if style="height:200" instead of height=200

RESOLVED INVALID

Status

()

Core
HTML: Parser
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: bugzillaspambox, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.5) Gecko/20060719 Firefox/1.5.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.5) Gecko/20060719 Firefox/1.5.0.5

Have a look at this page:

http://ontheserver.de/temp/Mozilla/Firefox/background-position/index.htm

2 times more or less the same table, the only difference is, that the height is defined different. The second table (with height=200) lets background-position and background-repeat work fine. But the first table (with style="height:200") messes everything up.

Reproducible: Always
(Reporter)

Updated

12 years ago
Summary: background-position:bottom and background-repeat:no-repeat doesn't works if style="height:200" instead of height=200 → background-position:bottom and background-repeat:no-repeat dont work if style="height:200" instead of height=200

Comment 1

12 years ago
The problem is that the first table has two style attributes. Combine the two and it works as expected.  The second one seems to be ignored.

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Component: General → HTML: Parser
Product: Firefox → Core
Resolution: --- → INVALID
Version: unspecified → Trunk
(Reporter)

Comment 2

12 years ago
well that's a trick to avoid the bug, isn't it?

polidobj@yahoo.com did you move the bug to a different section?

Comment 3

12 years ago
It's no trick.  Two style attributes are not allowed.  See Bug 257925. I suppose it could go in parser or CSS.  But I'm guessing the parser is doing nothing with the second style attribute as it doesn't get added to the DOM.
(Reporter)

Comment 4

12 years ago
Oops, I'm sorry. I didn't get what you meant to say the first time. You meant that there are 2 time style="..." right? I didn't notice :-/

Well anyway, in my eyes it should work anyway. Well guess the decision is been made long ago.
You need to log in before you can comment on or make changes to this bug.