The font for XML Files with no stylesheet should be the default monospace font

RESOLVED DUPLICATE of bug 327276

Status

()

RESOLVED DUPLICATE of bug 327276
13 years ago
13 years ago

People

(Reporter: noel.markham, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.5) Gecko/20060719 Firefox/1.5.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.5) Gecko/20060719 Firefox/1.5.0.5

The font for XML Files with no stylesheet should be the default monospace font rather than the default overall font. It is much easier to read structured data when all the characters line up underneath each other.
Since it is rare for a user to change the default overall font, as this can have implications on the viewing of other websites, the default font for XML with no stylesheet should be monospaced.

Reproducible: Always

Steps to Reproduce:
1. Open an XML file with no stylesheet attached, such as http://www.w3schools.com/xml/note.xml
2. The XML would be much easier to read if the font was fixed width
Actual Results:  
Viewing a non-monospaced font for the XML

Expected Results:  
Viewing a monospaced font for the XML
(Reporter)

Comment 1

13 years ago
Created attachment 231750 [details]
An XML file in a non monospaced font
(Reporter)

Comment 2

13 years ago
Created attachment 231751 [details]
The same XML file with a monospaced font - much easier to read

Perhaps the two images are trivial, but larger files are much easier to read in a monospaced font.
(Reporter)

Updated

13 years ago
OS: Windows XP → All

*** This bug has been marked as a duplicate of 327276 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.