Critical string changes for FF 1.5 - Connected Files feature, Bookmarks, Help call

VERIFIED FIXED

Status

VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: Tonnes, Unassigned)

Tracking

({fixed1.8.0.9, verified1.8.0.9})

unspecified
fixed1.8.0.9, verified1.8.0.9
Bug Flags:
blocking1.8.0.8 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.0.5) Gecko/20060719 Firefox/1.5.0.5
Build Identifier: 

This should fix some basic issues inside the nl locale for FF/TB 1.5.

- Compatibility with Connected Files feature is broken as currently no underscores are used where they (unfortunately) should for Dutch. See bug 232075.
- Shared access key for File menu and New bookmark button in Bookmarks manager, making the first one unusable as a new bookmark is always opened.
- Help section for Clear private data is not accessible very well, as a result of an erroneous sanitize-to-cpd change.
- A typo and a few bad translations for tooltips that reside in one of the CF feature related files.

Reproducible: Always
(Reporter)

Comment 1

12 years ago
Created attachment 231753 [details] [diff] [review]
The fix
(Reporter)

Comment 2

12 years ago
Created attachment 231761 [details] [diff] [review]
Tooltip for search bar

A minor tooltip+key issue I wanted to include but which could break the rest, as this file appears to have a CR/LF problem.
(Reporter)

Updated

12 years ago
Attachment #231753 - Flags: review?(bugzilla)
(Reporter)

Updated

12 years ago
Attachment #231761 - Flags: review?(bugzilla)
Attachment #231753 - Flags: review?(bugzilla)
Attachment #231753 - Flags: review+
Attachment #231753 - Flags: approval-l10n?
Attachment #231761 - Flags: review?(bugzilla)
Attachment #231761 - Flags: review+
Attachment #231761 - Flags: approval-l10n?
(Reporter)

Updated

12 years ago
Flags: blocking1.8.0.8?
(Reporter)

Updated

12 years ago
Attachment #231753 - Flags: approval-l10n? → approval1.8.0.8?
(Reporter)

Updated

12 years ago
Attachment #231761 - Flags: approval-l10n? → approval1.8.0.8?
Restoring lost blocking flag
Flags: blocking1.8.0.9?
Axel: are we taking localization changes in 1.5.0.8? I imagine so since we want to get the "major update available" patches in too, and in that case this is probably fine for 1.8.0.8 as well.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.8.0.8?
Comment on attachment 231753 [details] [diff] [review]
The fix

Axel, we'll take these in 1.8.0.8 on your approval.
Attachment #231753 - Flags: approval-l10n?
Attachment #231761 - Flags: approval-l10n?
Won't hold the release for it, but we'll approve the patches if Axel does.
Flags: blocking1.8.0.9?
Flags: blocking1.8.0.8?
Flags: blocking1.8.0.8-

Comment 7

12 years ago
Comment on attachment 231761 [details] [diff] [review]
Tooltip for search bar

[nl] accesskey fixes approved for 1.8.0.9.

Please use the fixed1.8.0.9 and verified1.8.0.9 keywords to track landing and testing.
Attachment #231761 - Flags: approval1.8.0.9?
Attachment #231761 - Flags: approval1.8.0.9+
Attachment #231761 - Flags: approval-l10n?

Comment 8

12 years ago
Comment on attachment 231753 [details] [diff] [review]
The fix

[nl] fix for connected files approved for 1.8.0.9.

Comment 9

12 years ago
Comment on attachment 231753 [details] [diff] [review]
The fix

[nl] fix for connected files approved for 1.8.0.9.
(setting the flag, too)
Attachment #231753 - Flags: approval1.8.0.9?
Attachment #231753 - Flags: approval1.8.0.9+
Attachment #231753 - Flags: approval-l10n?
Comment on attachment 231753 [details] [diff] [review]
The fix

patch applied on the 1_8_0_branch
Comment on attachment 231761 [details] [diff] [review]
Tooltip for search bar

patch applied to the mozilla_1_8_0_branch
both fixes are applied.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8.0.9
Resolution: --- → FIXED
verified: 
Mozilla/5.0 (X11; U; Linux i686; nl; rv:1.8.0.9pre) Gecko/20061126 Firefox/1.5.0.9pre
Status: RESOLVED → VERIFIED

Comment 14

12 years ago
Adding verified keywords according to Tim's comments.
Keywords: verified1.8.0.9
You need to log in before you can comment on or make changes to this bug.