targetting main window from new window

VERIFIED INVALID

Status

()

P3
normal
VERIFIED INVALID
19 years ago
17 years ago

People

(Reporter: ap23, Assigned: pschwartau)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
A new window was opened using window.open(...).  The new window had a link
targetted back to the main window, but opened the page in yet another new
window.  I've pasted the scripts below.

<SCRIPT LANGUAGE="javascript">
window.open('nextpage.html','joe',config='height=300,width=500,location=yes,status=yes,resizable=yes,toolbar=no,menubar=no,scrollbars=no,directories=no')
</SCRIPT>

<a href="thanksalot.html" target="main">Click here</a>

Comment 1

19 years ago
--> phil
Assignee: rogerl → pschwartau
The URL is now a 404. ap23@hotmail.com - can you provide another one?

Gerv
ap23@hotmail.com - we really need a new URL for this bug otherwise it's going to 
get closed :-(

Gerv
(Assignee)

Comment 4

19 years ago
I'm marking this one as 'Invalid'. The key to the reporter's HTML 
is the target attribute in the anchor tag: 

                          target="main"

In order for this to work as intended (that is, open the link in the parent 
window rather than a new window), 
the parent window should have a name attribute equal to "main". 

I have been able to do this without any problem with a Mozilla debug build on 
WinNT, made on 06/01/00. You launch a parent window as follows: 

     window.open(parentwindow.html','main',config='height=300, etc., etc.  )

This produces a window with name attribute equal to "main". From now on, the 
rest of the reporter's HTML works fine. A "nextpage" window comes up launched 
from the main window. This contains the anchor tag:

       <a href="thanksalot.html"target="main">Click here</a>

When you click on this, the "thanksalot.html" file comes up in the parent window 
named "main". It does not come up in yet a new window. The trick is to make sure 
that the parent window does indeed have the name "main" as an attribute...

As far as I know, "main" is not a reserved word, and must be actively assigned 
to the parent window. Without assigining this, you won't get back to the parent 
window from the anchor tag - either in Mozilla, Netscape 4.x, or IE4.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID

Comment 5

18 years ago
Source code problem not ours marking as Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.