After setting display:none on html,body, unsetting display:none doesn't make them reappear.

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

({regression, testcase})

Trunk
regression, testcase
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060802 Minefield/3.0a1

After setting display:none on html,body, unsetting display:none doesn't make them reappear.  This seems to be a painting problem, because if I press Cmd+A (Select All), the text does appear.

Regressed on trunk between 2006-03-29 and 2006-03-30.  Maybe a regression from 331458?
(Reporter)

Comment 1

12 years ago
Created attachment 231782 [details]
testcase
(Reporter)

Comment 2

12 years ago
This bug also seems to exist on Windows.  Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060731 Minefield/3.0a1
OS: Mac OS X 10.4 → All
Hardware: Macintosh → All

Comment 3

12 years ago
Funky. If you start selecting from right to left, the dom elements get visible one by one :-)

Comment 4

11 years ago
Hmm, WORKSFORME?
(Reporter)

Comment 5

11 years ago
WFM on Mac with a recent debug build.  Can someone retest it on Windows and mark the bug as WFM?

Comment 6

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/20070702 Minefield/3.0a6pre

Yep, WFM on Windows XP. I think this would make a good async. reftest.

->WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Flags: in-testsuite?
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.