Closed Bug 347048 Opened 14 years ago Closed 12 years ago

Too hard to file e-mail

Categories

(Thunderbird :: Mail Window Front End, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: elharo, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1

This is a tricky problem to describe but it's very, very real. Simply put, Thunderbird makes it vastly too hard to file and organize e-mail. I compare here with Eudora that I previously used. Eudora made it easy to file messages, including a menu just for that. Thunderbird does not

This is a combination of numerous factors, and I think a complete redesign is called for. There are multiple problems, some of which have been separately reported; but no one of which is a fix.  

Short version: I can label a message with one key press. That works. If I don't remember the key for a label, then it's right click-->Labels-->choose the label.   However I only have 5 labels which is too few. 

To organize things in different folders there are two approaches:

1. Drag and drop into the folders sidebar. The problem is two-fold:

  A. Folders are mixed up with accounts, and random things like Junk and Trash take up half the space. I can't even see all the folders at once, and I'm constantly expanding and collapsing. This even though I only have two accounts. For someone with more, it's hopeless.

  B. The fonts and icons are simply too small. They are hard to hit with the mouse. However making them larger leaves even less space in the Folders panel. 

2. Context menu. However putting a message into the right folder requires navigating through at least 4 hierarchical menus, and often more. That's at least two times too many.


I do not see an easy fix here. But I think the current setup is simply too hard to use. A redesign, perhaps after comparing other products like Eudora and Outlook, might help. 


Reproducible: Always
Summary: To hard to file e-mail → Too hard to file e-mail
I've given this some further thought. Last night it occurred to me that we're missing an additional level of direction we need. Categorization, organization, and sorting of the e-mail should be separate from the physical storage. For example, if I have two e-mail accounts I may get mail in both about Java. I should be able to see all my Java e-mail regardless of account. Furthermore I want to see it whether it's stored on an IMAP server or in a local folder.

I'm still playing with ideas but here's the germ of a proposal. Allow arbitrary tagging of messages, much like labels but not limited to 5. Furthermore allow a single message to be tagged with multiple labels. For instance, a message about working with SAX in Java might be tagged as XML and Java. 

Then provide a flat view of all the labels that would replace or supplement the current folder based sidebar. Possibly this could be hierarchical, but increasingly I think flat is the way to go. It's just easier. (See, for example, David Allen's Getting Things Done on the benefits of a flat filing system.)

UI-wise you could drag a message into a category, select an existing category from a context menu, or type a category into a text field in the message window and press a button.

All of this category detail and mappings from message IDs to categories would be stored as separate metadata by Thunderbird. It would not be stored in the mbox. , which would not need to change.

I know this is all non-trivial, and is still very rough. It's certainly not doable in the 2.0 time frame. It might even require a fork to experiment with the ideas and the UI. 

However I think more and more of us are just getting swamped by unmanageable inboxes. Some radical rethinking is required to figure out how to handle this. Google's playing with search in GMail as one solution, and that's probably part of it. However I'm not convinced human-assisted tagging isn't also part. (Just think about del.icio.us.) Currently Thunderbird's tagging via a fixed 5 labels is very weak. It could be a lot better.


One problem I foresee with keeping the category metadata separate from the physical storage is that it would not automatically sync with IMAP clients on other systems used to access the server-side mbox. However:

1. This wouldn't break anything that currently works.
2. Most of us have a primary system where we use Thunderbird to read out mail, and this is where we really need categories.
3. We can hack around this. 

In particular, the metadata could be copied to a particular IMAP folder on the servers such as ThunderbirdMetadata and embedded in or attached to an e-mail message in that folder if necessary. Then Thunderbird and other savvy clients could find and sync on the metadata in that folder. To all other clients it would just look like another e-mail message.
Maybe I was too pessimistic. Looking at the Thunderbird 2 release notes, message tags may actually be what I was describing or at least the foundation for it. I'll explore further. 
Message Tags in 2.0 is very close to what I was imagining. There's one crucial missing piece though. I now have Views of Favorite Folders, Recent Folders, Unread Folders, and All Folders. However there's no view that includes All Tags. I can create views for individual tags, but I have to do this manually for each tag; and the UI for doing so is not obvious and a little tricky. (I did it wrong the first time since I'd double tagged a message and needed to use "contains" instead of "is"). 

I definitely think the sidebar needs an "All Tags" variant; and perhaps this should be included as an option in All Folders along with foo@example.com, foo@example.org, news.example.com, and Local Folders.

But I still want more of a separation of storage from the UI. Perhaps something along the lines of Unread, Untagged, Trash, Junk, and one category for each tag,  or something like that. I might need to experiment with multiple options before deciding what organizational scheme makes sense. 

Then the question becomes whether that scheme is sufficiently generic to cross an 80/20 point, or does everyone need to customize their own organizational scheme? I'm not sure. 



Version: unspecified → 2.0
I think you should open a new bug for the capacity to specify "all" or "none" 
as a criterion of the Tag field; that would be straightforward and useful for all search features (filtering, quicksearch, message search, search folders).

The cascading menu for Copy/Move is a problem; so is the monolithic folder picker seen in the Filter dialog with the Copy/Move action.  There are multiple RFEs with various suggestions on improving this; try a search in mail frontend
& backend for "enhancement" with "any of" "Copy Move" to find some of these.

(In reply to comment #4)
> I now have Views of Favorite Folders, Recent Folders, Unread Folders, and
> All Folders. However there's no view that includes All Tags. [...]
> I definitely think the sidebar needs an "All Tags" variant

I'm not following this; the first set of views you mention is for folders, but "All Tags" is a message-level view, not folder-level.

But you can create a search folder associated with a particular view applied to any set of "real" folders.  You can mark that folder as a favorite, too.

It sounds like you're advocating creating a folder view that automatically 
shows a separate search folder for each defined tag.  (This is actually similar to what is being planned with the switchover of 'flag' to 'star' -- they intend to automatically create a search folder for starred messages.)  If in fact your mail organization leads you to having a large number of 'favorites', it seems sensible to me to be able to create multiple favorite views, which would probably involve a set of tags for folders, probably separate from the message tags.


> I can create views for individual tags, but I have to do this manually
> for each tag; 

You can also create a view for All Tags by using multiple criteria:
 Any of:
  Tag, contains, Important
  Tag, contains, To Do
  Tag, contains, Personal
etc.  This does need to be updated manually every time you create a new tag.
As best I can tell, the original request is satisfied by the improved tags support in 2.x.

Please do create a separate enhancement request for the "all tags" / "no tags" idea (it's easiest for the developers when there's only one specific request per bug report).

Search folders should give you the separation of storage and UI that you're looking for.

I'm going to resolve this as "invalid", for lack of a better resolution choice.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.