Closed Bug 347066 Opened 14 years ago Closed 11 years ago

Connection error messages disrupt normal application usage

Categories

(Thunderbird :: General, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 123440

People

(Reporter: petter.haggholm, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.5) Gecko/20060731 Firefox/1.5.0.5
Build Identifier: Thunderbird 1.5.0.5

When connection to any particular mail server cannot be established, an error message window is popped up to notify the user of this. That this can be disruptive is hardly surprising (in particular it is irritating when navigating folders with the arrow keys, since the popup on my system doesn't get the proper focus, forcing me to locate and use the mouse), but I also argue that it's not necessary or desirable. Some servers may have low availability, and sometimes universal connection failures occur ("Oops, did the wireless network drop me? Better re-establish it"), forcing the user to click away an error message for EACH mail server. (Personally, I have six, and one of them is a machine of my own with intentionally low uptime -- I use IMAP to backup my mail archives.)

My suggestion would be to replace this functionality with a subtler notification that does not interrupt normal usage. For example, instead of popping up a seperate window, a server could be tagged as unavailable with a changed server icon (similar to the little red and yellow icon that tags a folder with new mail).

Reproducible: Always
An Outlook style hide-able connection window would be a great way to solve this, and a much better way of keeping track of what Thunderbird's doing.

Petter's right - the current method is far too disruptive, especially if Thunderbird is checking multiple servers.
This bug does not adequately specify when the server polling is done on sending or a time activated polling of all server accounts that have this option selected in the Accounts Manager. For the latter, this would include news servers as well.

How the alert is displayed is annoying as it is a modal dialog that has to be clicked away to restore the interrupted activity. Can this be converted to a non-modal dialog displayed superimposed over the toolbar with the effected account named as the cause.
Duplicate of/related to bug 255360 -> bug 223131 -> Core bug 123440?
Assignee: mscott → nobody
(In reply to comment #3)
> Duplicate of/related to bug 255360 -> bug 223131 -> Core bug 123440?

Thanks sorry for the time it took to take action on this.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 123440
You need to log in before you can comment on or make changes to this bug.