establish optimum microsummary load timeout

RESOLVED FIXED in Firefox 2

Status

RESOLVED FIXED
12 years ago
3 years ago

People

(Reporter: myk, Assigned: myk)

Tracking

({fixed1.8.1})

2.0 Branch
Firefox 2
fixed1.8.1
Bug Flags:
blocking-firefox2 +

Details

Attachments

(1 attachment)

(Assignee)

Description

12 years ago
We now cancel microsummary loads after 10 seconds.  It occurs to me, after seeing mconnor using Dietrich's cool new Bugzilla bug list microsummary, that some legitimate microsummary loads could take a lot longer than that.  Bug lists, in particular, can occasionally take minutes to complete, and they regularly take more than 10 seconds.

We should figure out what the optimum load timeout is so that we don't leave dangling connections but also handle the vast majority of loads.  cc:ing darin for insight into this issue.
(Assignee)

Comment 1

12 years ago
The fix for this will be trivial, but it's important that we get this right, so this should block the release.
Status: NEW → ASSIGNED
Flags: blocking-firefox2?

Updated

12 years ago
Flags: blocking-firefox2? → blocking-firefox2+
(Assignee)

Comment 2

12 years ago
I talked about this with Darin, and he suggested that we establish a limit of 5 minutes, which is high enough not to time out on almost any site (including Bugzilla installations that can take minutes to return results) while being low enough not to let connections build up (since automatic updates never fire more frequently than once every 30 minutes when loads are hanging).

Patch coming up.
(Assignee)

Comment 3

12 years ago
Created attachment 233877 [details] [diff] [review]
patch v1: changes timeout from 10 to 300 seconds

Here's the trivial fix for this bug.  It just changes the timeout from 10 to 300 seconds (i.e. five minutes) and updates the comment accordingly.
Attachment #233877 - Flags: review?(mconnor)

Updated

12 years ago
Attachment #233877 - Flags: review?(mconnor) → review+
(Assignee)

Comment 4

12 years ago
Fix checked in to the trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

12 years ago
Comment on attachment 233877 [details] [diff] [review]
patch v1: changes timeout from 10 to 300 seconds

Notes for drivers considering this approval request:

This patch changes the amount of time before we abort a microsummary load from 10 seconds to five minutes.  The goal of the timeout is to prevent loads that never complete from building up, but we want to make sure we don't prematurely cancel loads that merely take some time to complete (f.e. Bugzilla queries).

The patch is trivial, and the risk of regression is low.  Although I only resolved the bug this morning, the patch has actually been on the trunk since yesterday (Tuesday, August 15) afternoon.
Attachment #233877 - Flags: approval1.8.1?
Comment on attachment 233877 [details] [diff] [review]
patch v1: changes timeout from 10 to 300 seconds

a=beltzner on behalf of drivers, for landing on the MOZILLA_1_8_BRANCH. Please mark fixed1.8.1 when it lands.
Attachment #233877 - Flags: approval1.8.1? → approval1.8.1+
(Assignee)

Updated

12 years ago
Keywords: fixed1.8.1
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.