Thunderbird consistently fails to download particulare e-mail with attachments via IMAP or POP

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
critical
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: Tom Tyson, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.5) Gecko/20060719 Firefox/1.5.0.5
Build Identifier: version 1.5.0.5 (20060719)

I'm downloading from a corporate exchange server.  Using POP I consistently get failures to download certain messages (always with attachments).  It's about every 80-140 messages with attachments, or about every 300-500 messages.  The download hangs, I have to use outlook to find the message after the one downloaded, delete it, 'empty deleted items' (causes a compact?), then restart thunderbird to begin downloading again.  Eventually thunderbird just stops trying and sits there. 

I have nearly the same issue downloading IMAP e-mail to a local folder.  However, generally by working one message at a time I can overcome the issue.  Not so with the POP download.  I had been deleting messages, but I found that in some cases I could use an IMAP account in thunderbird hitting the same e-mail inbox on the exchange server to manually copy down that one message and get the POP download going again after a restart.

While our corporate exchange server may be misbehaving in some way, I need to know what to ask our admins to fix.  The server works fine with Outlook, and thunderbird has to be restarted in some cases to make progress.  If Thunderbird is in no way at fault, I don't think a restart should be required.

Reproducible: Always

Steps to Reproduce:
1.  Click 'Get Mail' (I'm configured so nothing is automatic currently.)
2.  Wait for the Downloading message count to stop for more than 30 seconds.


If there is some way for me to trace my POP transaction, without actually sending the bits and bytes of the messages out of the company I can try to get that trace.
Actual Results:  
Thunderbird stops downloading

Expected Results:  
Thunderbird continues downloading

I'm running a fresh install with a fresh profile.  Problem existed before and after I copied over an existing abook.mab.

I've had this sort of issue for quite some time with Thunderbird, but it seems to be getting worse.  Others in my office have the same issue.  The first time I logged a bug against Mozilla for a similar issue (sorry I could not find any record of it now.), the discussion ranged to questions about how the exchange server reported the size of attachments only approximately in some cases.  Never was resolved as far as I know.

Comment 1

12 years ago
do you have a virus checker installed? virus checkers have been known to cause problems like that in the past.
(Reporter)

Comment 2

12 years ago
Symantec Antivirus 9.0.3.1000
Can you clarify, what should I try to narrow it down.  I can't unninstall.  I might be able to dissable it briefly.
(Reporter)

Comment 3

12 years ago
I realized there was another possibility:
http://www.digitalriver.com/dr/v2/ec_dynamic.main?SP=1&PN=10&sid=26412
That one seemed to make a difference. 2100 e-mails and counting with no hang.

Comment 4

12 years ago
yeah, I guess that has similar potential to make it look like the server has hung...

Comment 5

12 years ago
can you resolve this WFM or Invalid if it turns out to because of digital river?
(Reporter)

Comment 6

12 years ago
OK so this was an interaction with Black Ice from Internet Security Systems.  I'll see if there's anything I can do to get this reported to ISS.  Is there any way to get this added to a troubleshooting page or tips page in the Thunderbird docs?  I I wasn't able to google anything on this issue, even after knowing Black Ice was involved. I'm not the only one having this problem in my office.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.