Closed Bug 347143 Opened 16 years ago Closed 15 years ago

[Http Auth] Firefox does not save new password if it already has an old password

Categories

(Toolkit :: Password Manager, defect)

1.8.0 Branch
x86
Windows 2000
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: timwi, Unassigned)

Details

(Whiteboard: CLOSEME 07/05)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.5) Gecko/20060719 Firefox/1.5.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.5) Gecko/20060719 Firefox/1.5.0.5

See STR

Reproducible: Always

Steps to Reproduce:
1. Go to a site that requires HTTP authentication. Username/password dialog pops up.
2. Enter your username and password, and tell Password Manager to save it.
3. Change your password on the site.
4. Close and restart Firefox.
5. Visit the site again. It will ask for username and password again, with the previously saved values pre-filled. Pressing Enter makes the dialog re-appear immediately because the password is wrong.
6. Enter your new password and tell Password Manager to save it. Site lets you in. BUT...
7. Close and restart Firefox. Visit the site again.
8. Username and password box pops up again, seemingly with the saved values pre-filled, but pressing Enter makes the dialog re-appear again. I believe this is because Firefox is still remembering the old password.
Actual Results:  
When entering the new password in the HTTP auth username/password dialog, Firefox DOES NOT save it (even when told to do so) if there is already a saved password for that username.

Expected Results:  
Firefox should save the password when asked to do so. The old password for the username should be deleted.
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/05
Version: unspecified → 1.5.0.x Branch
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.