Bon Echo overwrites the "Force links" tab preference in 1.5.0.6

RESOLVED WONTFIX

Status

()

Firefox
Preferences
RESOLVED WONTFIX
12 years ago
6 years ago

People

(Reporter: dria, Unassigned)

Tracking

2.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Steps to reproduce:

1. Check the "Force links that open new windows to open in:" tab preference in 1.5.0.6
2. Quit 1.5.0.6 and start Bon Echo using the same profile
3. Quit Bon Echo and start 1.5.0.6
4. Check tab preferences -- the "Force links that open new windows" checkbox is now unchecked
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Yeah, I guess that's because opening links in tabs (not in windows) is default in BonEcho so there won't be written a pref to prefs.js. 
Yeah, there isn't really anything we can do about this, given the way the pref system works. If a pref is equal to the default, it's entry in user.js is removed, so when you start a build with a new default, it's used instead.
I'm'a recommend closing this bug, maybe as WORKSFORME or INVALID or OBSOLETE ;)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.