CPU Spikes to 100% and Bon Echo hangs out without error

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: David Miller, Unassigned)

Tracking

({hang})

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060803 BonEcho/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060803 BonEcho/2.0b1

Bon Echo seems to be hanging on me at random intervals without any sensible way to reproduce the error(s).  It has been happening to me since B1 was released to the public.  I was thinking perhaps this was originally a cousin of #346308 but it doesn't seem to be that way since a fix was tracked in to fix that (and my issue predates 346308).

Reproducible: Always

Steps to Reproduce:
1.  Start Bon Echo
2.  Navigate around the web

Actual Results:  
Bon Echo will eventually stop working -- most notably around sites with a lot of activity such as Flash, AJAX or similar things.  The CPU usage on the processes list will spike up to 100% and the memory usage will go as high as 128k and it eventually will hang out and die (without TB incident btw!)

Expected Results:  
It should not do this?

I am at a *TOTAL* loss for words on how to reproduce this or even get any information back off this problem.  All I can say is it started on B1 and has NOT relented since the fix for #346308 was checked in.

It is less recurrent now that that fix is in place which leads me to believe I was suffering from two separate bugs with the same symptoms.  I'm totally willing to run debug builds or anything needed to track this.  However, I'm unable to get any reliable information from any possible ways I know how so far.
Could this be a duplicate or a possible side-effect of 346233 ?
Depends on: 346233
(Reporter)

Comment 2

12 years ago
I did not realize it until later, but SteveE pointed out that the time my bug started pre-dates that of 346233 so it's unlikely it is a direct result of it.  It could be a bug which was contributing TO 346233 though, that's possible :-*

Comment 3

12 years ago
Hang != crash. I doubt there's much we can do here without a stack for the hang. I think you will need to get a Windows debugger and somehow attach to the process and get a stack.

Are you using any extensions? If so, can you try using Bon Echo for a day or two without them and see if you still see this?
Severity: critical → major
Keywords: hang
Summary: CPU Spikes to 100% and Bon Echo crashes out without error → CPU Spikes to 100% and Bon Echo hangs out without error
Version: unspecified → 2.0 Branch
(Reporter)

Comment 4

12 years ago
Well, I know a crash and a hang are different.  It does both, hangs then crashes out :)

No extensions, running a new profile and safe-mode both produce the error as well.  Affirmative on the debugger idea, I'll give that a whirl when I have some free time to toss around.
(Reporter)

Comment 5

12 years ago
Okay, I was looking at a website recently and the browser locked up and refused to do anything.  After a couple of minutes Dr Watson interrupted and told me a memory dump and a log were created of the incident, I grabbed them for your viewing.  See attachments.
(Reporter)

Comment 6

12 years ago
Created attachment 232019 [details]
crash manifest
(Reporter)

Comment 7

12 years ago
Created attachment 232020 [details]
appcompat
(Reporter)

Comment 8

12 years ago
I had no place to upload the dump file so I put it on YouSendIt (lame huh?)

http://www.yousendit.com/transfer.php?action=download&ufid=4F1CF65577BCC32E

^ dump-file for your downloading pleasure.

Comment 9

12 years ago
David, you might want to ping timeless on IRC to figure out how to go about analyzing that log file. I'm really not sure how to do that (nor am able to since I'm on Linux).
A hang was recently fixed in bug 346233, so it's possible that this bug has been fixed. Please leave a comment if you are still able to reproduce this with a recent nightly from the branch, otherwise we'll close this as fixed.
(Reporter)

Comment 11

12 years ago
Looks like this is fixed now.  I will poke around with it some more but I haven't seen it since the fix was put in, which is a really good sign.
(Reporter)

Comment 12

12 years ago
nope, still happening.  I will ping Timeless about this later tonight and see what he thinks :-)
(Reporter)

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Comment 13

11 years ago
This has not happened for almost a week now.  I am going to go with resolved on this one.  I'll see if I can figure out what landed and fixed it however, it's fixed so that's all that's important. :-)

Comment 14

11 years ago
->WORKSFORME since we can't pinpoint a specific patch that fixed this.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.