Ability to filter search by app version

RESOLVED DUPLICATE of bug 372841

Status

defect
RESOLVED DUPLICATE of bug 372841
13 years ago
3 years ago

People

(Reporter: cameron, Unassigned)

Tracking

Dependency tree / graph

Details

(Reporter)

Description

13 years ago
With the release of Fx 2 this is going to become far more useful/important for users - most add-ons won't be updated.

We can either sniff the useragent and only show compatible add-ons, or we could provide another dropdown box (greyed out until app is selected) where the user can select the version they want the add-on to be compatible with.

If we did have UA sniffing, we'd want the ability to turn it off (eg, use a checkbox "Only show compatible add-ons")

Target milestone: September
(Reporter)

Comment 1

13 years ago
*** Bug 351094 has been marked as a duplicate of this bug. ***

Comment 2

13 years ago
The reason stated by the original submitter is exactly why I arrived here - most of the extensions are not compatible with Firefox/2.0b2 and looking through the list for the few which are already updated is no fun at all.

I realize that most extension owners will probably update soon after the release but still it would be a nice feature to have (and I'd guess easy to implement?)
*** Bug 355419 has been marked as a duplicate of this bug. ***
*** Bug 356426 has been marked as a duplicate of this bug. ***

Comment 5

13 years ago
I would like the version filter to be set with the version of my browser when I visit the addons page.  The version filter should be on every page.  There are so many addons and many of them are incompatible with the most current version.  A filter would be a great help.

The filter should be an editable dropdown pre-populated with the version numbers of the supported major milestones plus the version of the browser (as it may be alpha, beta or release candidate) if it does not already on the list.  The browser version should be pre-selected and user should be able to enter their own value for advanced searches.
(Reporter)

Comment 6

13 years ago
*** Bug 358532 has been marked as a duplicate of this bug. ***
Blocks: 372841
Target Milestone: --- → 3.x (triaged)
Version: 2.0 → 3.0

Updated

12 years ago
Target Milestone: 3.x (triaged) → 3.4
Duplicate of this bug: 297687
Duplicate of this bug: 417787
Duplicate of this bug: 426965

Updated

11 years ago
No longer blocks: 372841
Depends on: 372841

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 372841
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.