Accessibility issues on Options-Privacy page

RESOLVED DUPLICATE of bug 344572

Status

()

Firefox
Disability Access
RESOLVED DUPLICATE of bug 344572
11 years ago
11 years ago

People

(Reporter: Wayne DeAngelo, Unassigned)

Tracking

({access, sec508})

Trunk
x86
Windows XP
access, sec508
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Test environment:
   Windows XP, Firefox 2 (Bon Echo) build 20060802, Inspect Objects
   Optional: screen reader (JAWS or Window-Eyes)

Description: 
Accessibility issues found on the "Privacy" tab of the Tools-Options dialog.
1. Missing MSAA Name in "Remember visited pages fo the last" text input field
2. Screen reader does not read sentences containing multiple user interface elements.

Steps to recreate:
1. Open Tools-Options dialog (press Alt+T, then "O")
2. Select the "Privacy" page  (Press Tab or Shift+Tab until focus is on one of the icons at the top of the page, then press Right Arrow or Left Arrow until "Privacy" is selected.)
3. Press Tab to move focus to the "Remember visited pages for the last" field in the History section.
4. Press Tab one more time to focus on the input box for number of days. 
5. Note the Inspect Objects output: The MSAA Name = "" (null).  It should contain a meaningful label.
6. When you Tab to the "Remember visited" checkbox, or to the text entry field, note that the screen reader  never reads the entire sentence.  (JAWS and Window-Eyes output differ slightly, but neither ever says the word "days".  

Note: Visual constructions like this (radio button, followed by another UI element like a input field or combo box), followed by more text are not very easy to understand when using a screen reader, since the screen reader often reads only one element at a time, and not the entire line, as a sighted user would naturally do.

Expected results:
1. The MSAA Name property should be set for all User Interface elements.
2. The "Remember visited pages..." option should be reworded so as not to depend on a visual sentence structure containing multiple UI elements.  A possible solution is to make the MSAA Name of the input field something like: Name="Number of days to remember".

Updated

11 years ago
Blocks: 340667

Updated

11 years ago
Blocks: 340677
No longer blocks: 340667
This should be fixed by bug 344572; is it?  You'll need to either use the next nightly or a tinderbox build to check.
Status: NEW → ASSIGNED

*** This bug has been marked as a duplicate of 344572 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.