serious error and system crash after updating firefox

RESOLVED WORKSFORME

Status

()

Toolkit
Application Update
--
critical
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: Paul Agius, Unassigned)

Tracking

({crash})

1.8.0 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 07/14)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

Firefox automatically updated itself and I installed the update and restarted Firefox. The program restarted and worked normally for a few minutes. Then I left my computer to take a **** and when I came back the blue screen of death greeted me with a message saying that "a problem had been detected", namely:

"DRIVER_IRQL_NOT_LESS_OR_EQUAL"
....
"Technical Information:
STOP: 0X000000D1 (0X687F9D84, 0X00000002, 0X00000000, 0X841DA757)"

It then proceeded to dump the physical memory and prompt a restart. When I restarted, the MS error report screen appeared that documented the error as the following:
"BCCode : 100000d1     BCP1 : 687F9D84     BCP2 : 00000002     BCP3 : 00000000
BCP4 : 841DA757     OSVer : 5_1_2600     SP : 2_0     Product : 256_1"

And included the following files (Note: "Zephyr" is my username):
C:\DOCUME~1\Zephyr\LOCALS~1\Temp\WERadd7.dir00\Mini080306-01.dmp
C:\DOCUME~1\Zephyr\LOCALS~1\Temp\WERadd7.dir00\sysdata.xml

The Microsoft analysis said that the problem involved a device driver, and was caused by either a new hardware device or new software. Since I have not installed any new hardware recently, but just installed the Firefox update, process of elimination strongly indicates that the Firefox update somehow caused this major crash. 

I would like some information on how to resolve this such that it does not happen again.


Reproducible: Couldn't Reproduce

Steps to Reproduce:
A sporadic blue screen error like this can't be easily reproduced, and trying to trigger a total system failure on your computer is moronic anyway.
As you say, a system driver crashed rather than Firefox, so I'm inclined to think that this is just a coincidence. MS didn't happen to say what the driver was ? Have you had further crashes while Firefox is running ?

Comment 2

11 years ago
stick C:\DOCUME~1\Zephyr\LOCALS~1\Temp\WERadd7.dir00\Mini080306-01.dmp onto a web server and provide a url for it. i'll arrange to get some information about which vendor you should be yelling at (it won't be us, i can assure you of that in advance).
(Reporter)

Comment 3

11 years ago
"MS didn't happen to say what the driver
was ? Have you had further crashes while Firefox is running ?"

Microsoft said "A device driver installed on your computer caused the problem; however, we cannot determine the precise cause." 
And then it added:
"    * If this problem occurred after you installed a new hardware device on your computer, the problem might be caused by the driver for the device. Use the Driver Rollback utility or uninstall the driver.
    * If this problem occurred after you installed new software, the software might have installed a driver that caused the problem. Try uninstalling the software."

I haven't uninstalled Firefox, and this hasn't occurred again so far. However, I still think Firefox was the problem's source because last night before the crash I restarted Firefox after the update installed and got the "You have successfully updated Firefox" message. Then I used Firefox for a bit before the major crash, had the major crash and restarted my computer, and then re-opened Firefox to get that same message "You have successfully updated Firefox." So it seems to me that something went awry with the update process. Today, I recieved no welcome screen and the browser seems to be working normally.

"stick C:\DOCUME~1\Zephyr\LOCALS~1\Temp\WERadd7.dir00\Mini080306-01.dmp onto a
web server and provide a url for it."

The directory and file contents "WERadd7.dir00\Mini080306-01.dmp" have disappeared from my temp files. However, I did a search for "Mini080306-01.dmp" on my hard disk and found another file by that name in "C:\Windows\Minidump". It is actually the only file in that directory, and the file and directory were created on Aug. 3 at 9:05 PM - around the time of the crash - so I think it is a duplicate. I have uploaded that file to:
http://www.box.net/public/static/voqttz64lh.dmp 
(the filename was changed automatically by the hosting server when I uploaded it)

Comment 4

11 years ago
After installing Mozilla Firefox my browser now crashes several times a day.  The error report says this: Upgrade for Firefox recommended

Thank you for submitting an error report.

Problem description

An error occurred in your Firefox. Firefox was created by Mozilla Firefox.

Recommendation

A solution is not available for the specific problem you reported; however, Mozilla Firefox has informed Microsoft that a new version of Firefox is available. The new version may not fix the error you reported, but Mozilla Firefox recommends that you install it. To learn more about the update, click the link below.

(In reply to comment #4)

Please file a new bug for that. Talkback ID's would be invaluable (http://kb.mozillazine.org/Talkback)
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Keywords: crash
Whiteboard: CLOSEME 07/14
Version: unspecified → 1.5.0.x Branch
(Reporter)

Comment 7

11 years ago
The problem does not appear to be in the latest version; Closing thread...
 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.