PNG image not displayed but is in IE, ACDSee and Fx 1.0.8

RESOLVED DUPLICATE of bug 283214

Status

()

Core
ImageLib
RESOLVED DUPLICATE of bug 283214
11 years ago
11 years ago

People

(Reporter: teoli, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

The image of the URL is not displayed (indicates it is invalid). I'm unable to know if it is really an invalid PNG, but it has been reported to displayed fine in other tools (see http://forums.mozillazine.org/viewtopic.php?t=447715 )

Reproducible: Always

Steps to Reproduce:
1. Load the URL
2.
3.

Actual Results:  
Error message

Expected Results:  
Image displayed

The interesting point is the fact that there is a regression.

Comment 1

11 years ago
Created attachment 232099 [details]
PNG image which is not displayed in FF 1.5.0.5 and FF 3 trunk.

Generated images (see attachment) opens in WindowsXP Paint, Word (and other Office Tools), IrfanView and OpenOffice 2.0.3 but not in FF 1.5.0.5, 1.5.0.6 and FF 3 trunk.

Comment 2

11 years ago
A few more data points: 

That image doesn't display in Opera v9.01 either.  

Atempting to display with Mozilla v1.7.13 produces the message "The image “https://bugzilla.mozilla.org/attachment.cgi?id=232099” cannot be displayed, because it contains errors."

A broken-image icon is seen with the Konqueror browser (KDE v3.5.3).

Comment 3

11 years ago
The image has the "invalid distance too far back" zlib error.  Marking as dupe of bug #283214.

*** This bug has been marked as a duplicate of 283214 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.