Warning: Unresponsive Script <error>

RESOLVED WORKSFORME

Status

()

Core
General
--
major
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: Ricardo, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

After going to the demo site http://freetextbox.com/demos/ there is a textbox on the web-page. It has text box that used to work with the previous version of Firefox. It sits there and spins, the textbox is not accessable for typing, then finally a popup window appears with the following message;

"A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete."

two buttons with the options "Stop Script" or "Continue", either option does nothing.

Reproducible: Always

Steps to Reproduce:
see above
Actual Results:  
freeTextBox component is not accessable (cant type in it)


Please Help!

We have implemented this component (FreeTextBox – see below) throughout our HRMS web-application using MS .Net 2.0. Prior to updating to Firefox 1.5.0.6 I was using 1.5.0.5 and had NO ISSUES with the previous version. But since accepting the auto update then having firefox restart and install the new version WE can no longer access the Text Box. Again this was working fine before the update.

A)	How can I go back to the earlier version?
B)	Is there a setting that I can set for the Script Error (see below)??
C)	Can you confirm that there is an issue or not??

I have supplied a URL to the component so that you can test it from your side, 
Much appreciation to a rapid response,
Sincerely,
Ricardo Saucedo
ricardo.saucedo@catavo.com
Software Consultant
(Reporter)

Comment 1

12 years ago
Created attachment 232130 [details]
screenshot of script error
(Reporter)

Comment 2

12 years ago
Created attachment 232131 [details]
screenshot of FreeTextBox.Com site
WFM with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Maybe you could try setting dom.max_script_run_time to a higher value.
http://kb.mozillazine.org/Dom.max_script_run_time
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1b1) Gecko/20060804 BonEcho/2.0b1 ID:2006080403

I'm seeing this too (new profile). It doesn't happen every time, but within a few ctrl-f5's firefox consumes 99% CPU until the 'slow script' dialog pops up.

I also installed some 1.5.0.x releases of firefox, and I still see this problem with:
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6 (official release, new profile)
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.5) Gecko/20060719 Firefox/1.5.0.5 (official release, new profile)
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4 (official release, new profile)

So it is not a regression between 1.5.0.5 and 1.5.0.6 as comment 0 implies (there was one bug fix between 1.5.0.5 and 1.5.0.6, and that effected mms:\\ feeds)

It is, however, a valid bug, since sometimes it works and other times doesn't.

Updated

12 years ago
Severity: critical → major
re: comment 5
I still see this with a new profile on:
- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1b1) Gecko/20060804 BonEcho/2.0b1 ID:2006080403
so the increase in the dom.max_script_run_time from 5s to 10s still doesn't stop this problem; at least for me.
Component: Form Manager → General
Product: Firefox → Core
QA Contact: form.manager → general
Version: unspecified → 1.8 Branch

Comment 7

11 years ago
Ricardo, does error go away for any (increased) value of dom.max_script_run_time ?
what type of internet connection?

Consistently WFM, trunk build.

Comment 8

10 years ago
stevee. reporter appears to be gone
With Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11 I still get the slow script warning at http://freetextbox.com/demos/ with a new profile.

But with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008020112 Minefield/3.0b3pre ID:2008020112 and a new profile, I've been unable to reproduce.

Comment 10

9 years ago
(In reply to comment #9)
> 
> But with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre)
> Gecko/2008020112 Minefield/3.0b3pre ID:2008020112 and a new profile, I've been
> unable to reproduce.

let's call it WFM!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.