drawImage clipped to current path

RESOLVED FIXED

Status

()

Core
Canvas: 2D
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Philip Taylor, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1b1) Gecko/20060804 BonEcho/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1b1) Gecko/20060804 BonEcho/2.0b1

When drawImage is called while a non-empty path exists, the altered region of the canvas is clipped to that path instead of to the destination rectangle. This seems to happen regardless of any scaling. It still occurs when compiled with the patch in bug 346421.

Reproducible: Always

Steps to Reproduce:
1. See test case.
2.
3.

Actual Results:  
The first image is drawn in the correct position, but clipped to the green rectangle instead of being the specified 64x64 pixels. The second and third images are drawn correctly as 64x64 (presumably because the first drawImage clobbers the path, as in bug 296904).

Expected Results:  
The three images should look the same.
(Reporter)

Comment 1

11 years ago
Created attachment 232143 [details]
test case
This is not something that has regressed at least. I see the the same picture also with the 1.8.0.6 build.
Depends on: 346421
Keywords: testcase
Should be fixed by the patch for bug 346421 (the trunk one is in, branch patch going in shortly).
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

11 years ago
Thanks - works for me in the 1.8 branch now.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.