If a readonly engine has updates, and the icon load callback runs first, an exception is thrown

RESOLVED FIXED in Firefox 2 beta2

Status

()

Firefox
Search
--
major
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Gavin, Assigned: Gavin)

Tracking

({fixed1.8.1})

2.0 Branch
Firefox 2 beta2
fixed1.8.1
Points:
---
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

This is the cause of http://forums.mozillazine.org/viewtopic.php?p=2412032#2412032 . We should not even try to update read-only engines.
Created attachment 232228 [details] [diff] [review]
patch

The problem is that we're starting an update load for a readonly engine, and the icon load callback doesn't check whether the engine is readonly before trying to write to the file, but the file load callback does. Instead of checking in both callbacks, this just refuses to start an engine update load if the engine is readonly.
Assignee: nobody → gavin.sharp
Status: NEW → ASSIGNED
Attachment #232228 - Flags: review?(mconnor)
Flags: blocking-firefox2?
Target Milestone: --- → Firefox 2 beta2
Summary: If a readonly engine has updates, and the icon load callback loads first, an exception is thrown → If a readonly engine has updates, and the icon load callback runs first, an exception is thrown

Updated

12 years ago
Attachment #232228 - Flags: review?(mconnor) → review+

Updated

12 years ago
Attachment #232228 - Flags: approval1.8.1+

Updated

12 years ago
Flags: blocking-firefox2? → blocking-firefox2+
mozilla/browser/components/search/nsSearchService.js 	1.1.2.57
mozilla/browser/components/search/nsSearchService.js 	1.69
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.