XHTML served as application/xhtml+xml can't find CSS

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: aaron, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible;MSIE 6.0;Windows 98)
Build Identifier: Mozilla Debian Package 1.7.12-1.1

i am trying to serve XHTML with its correct mimetype. when i switched from text/html to application/xhtml+xml the browser no longer found the CSS file, though the <link> was intact inside the <head>. this stumped myself and several people in freenode #css. i made a test case and replicated it in mozilla.

my only other thought is that it might represent a misconfiguration of apache, but that's just conjecture.




Reproducible: Always

Steps to Reproduce:
1. load test file in browser


Actual Results:  
i see the XML tree.

Expected Results:  
i should see the CSS-formatted XHTML.


i will attach the short test case to this bug.
(Reporter)

Comment 1

12 years ago
Created attachment 232274 [details]
PHP/XHTML test case to demonstrate the failure of the CSS link.
any messages in the javascript console?
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> any messages in the javascript console?
> 

i doubt if this is relevant, but i see:

"event.target.rel has no properties
chrome://global/content/bindings/tabbrowser.xml Line: 786"

Comment 4

11 years ago
Some sites I know of are using PHP for this. But none ever had a problem like described here.

I also just tried this on my local machine and couldn't reproduce it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.