After landing of https://bugzilla.mozilla.org/show_bug.cgi?id=345466 icons in Options look like they were pieced together from different themes

VERIFIED INVALID

Status

()

VERIFIED INVALID
13 years ago
13 years ago

People

(Reporter: BoxerBoi76, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060804 BonEcho/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060804 BonEcho/2.0b1

After landing of https://bugzilla.mozilla.org/show_bug.cgi?id=345466 icons in Options look like they were pieced together from different themes and have an incoherent look and feel.  This bug is about providing a consistent looking set of icons for Options (as well as the rest of FF, that actually looks like a visual refresh and not visual chaos) that don't look circa 1990.

Reproducible: Always

Steps to Reproduce:
1) Launch FF
2) Observe that the "refreshed" icons are washed out and don't fit well with recent versions of Windows
3) Navigate to Tools-> Options and observe that the icons look circa 1990 and feel like they were pieced together from different sources/themes

Actual Results:  
Disappointment.

Expected Results:  
A well thought out 2006 look and feel that fits with Windows
(Reporter)

Updated

13 years ago
Flags: blocking-firefox2?

Comment 1

13 years ago
Hahahahahahhah, its so true. This new theme is so terrible. 
The icons in the Options window should have the same size, style and color style as the toolbar icons.
I think the toolbar items look nice and professional but there's a certain lack of color indeed. Especially the red component is under represented and most icons are a bit pale IMHO.
Bugs about "the theme sucks" aren't useful. If you have specific issues, please file bugs and mark them as blocking bug 347454.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Flags: blocking-firefox2?
Resolution: --- → INVALID
(In reply to comment #3)
> Bugs about "the theme sucks" aren't useful. If you have specific issues, please
> file bugs and mark them as blocking bug 347454.
>
In my idea this was a specific issue Gavin. The icons of the Options windows don't match together and differ in style, color etc. from the toolbar icons.
(Reporter)

Comment 5

13 years ago
I honestly don't know how anyone can state that the new/recycled icons in Options are consistent in design and convey a coherent "theme".  I believe the fact that the icons look "amateurish" at best is a valid bug.  There are countless bugs regarding bad look and feel in bugzilla, many of which are never marked invalid.

~B
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 6

13 years ago
Gavin, I never stated that the "the theme sucks" anywhere in this bug.  It's quite obvious that the icons look like they were pieced together from different themes.  That's all I'm saying and requesting that they be given another look.  A few are of varying sizes as well.

~B
(Reporter)

Updated

13 years ago
Blocks: 347454
"icons look like they are pieced together from different themes" is an entirely subjective statement. The icons were all created to be used in the Firefox theme. Filing a bug to "[request] that they be given another look" is not useful, and frankly quite arrogant. If your problem is that they aren't all the same size, then file a bug about that. This bug as filed is invalid, please don't reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 8

13 years ago
For the record half the "depends on" bugs in your bug https://bugzilla.mozilla.org/show_bug.cgi?id=347454 are subjective and purely based on the bug reporters opinion, which is no different then this bug.  I don't see them being marked in valid.

I'm really tired of the subjective nature of marking bugs invalid.  I'll just do it for you.

~B
Unfortunately, I have to agree that the Options icons don't go together. It's not only about sizes, it's about the style of the icons. It's not about another style but *one* consistent style. Gavin, do you agree that this can be addressed by a bug? If so, how should such a bug look like?

FWIW, Bryan should have acted soberer, but arrogant verbalization shouldn't make this bug invalid, because it's still worth being discussed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.