If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Support WebKit's .webplugin plugins

RESOLVED WONTFIX

Status

()

Core
Plug-ins
--
major
RESOLVED WONTFIX
11 years ago
5 years ago

People

(Reporter: MAU, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1b1) Gecko/20060803 Camino/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1b1) Gecko/20060803 Camino/1.0+

I have just installed the new Flip4Mac to view the Windows Media content. Camino recognize only the Flip4Mac WMV Plugin.plugin that allows to view the media content calling a QT window but not the Flip4Mac WMV Plugin.webplugin that allows to see the wm files inside the browser (this plugin works finein Safari)

Reproducible: Always

Steps to Reproduce:
1.install Flip4Mac 2.1
2.see Help > Installed plug-in in camino
3.see Help > Installed plug-in in safari

Actual Results:  
camino doesn't recognize flip4mac WM plugin.webplugin

Expected Results:  
camino recognizes and uses flip4mac WM plugin.webplugin

Comment 1

11 years ago
WFM using yesterdays 1.8 Branch build.

I suggest you perform the following steps, then post back if Flip4Mac 2.1 still don't show up:
1. Quit Camino
2. Delete ~/Application Support/Camino/pluginreg.dat
3. Launch Camino
(Reporter)

Comment 2

11 years ago
nothing is changed.. i have deleted pluginreg.dat and then launched camino.. Flip4mac plugin.webplugin 2.1 doesn't appear in the installed plugin.. only the plugin.plugin is recognized

Comment 3

11 years ago
Ok, now I understand what you mean.
I see that Safari list the "Flip4Mac WMV Plugin.webplugin", while Camino do not.

But from what I see Safari also use the QuickTime Player interface when it display movies inside the browser. The players look identical to me, in both Camino and Safari, so I don't think the missing .webplugin makes a difference.


I will let someone more knowledgeable with Gecko plugins decide if this is a feature we want/need to support, or not.

Comment 4

11 years ago
.webplugin is a non-standard, WebKit-only plugin format. If there is missing functionality in the .plugin version, you should take that up with Flip4Mac.

Josh, are there eventual plans to try to support .webplugin, or is this INVALID?
-> Core: Plugins, at the very least, pending Josh's response.
Component: Plug-ins → Plug-ins
Product: Camino → Core
QA Contact: plugins → plugins
Summary: Camino doesn't recognize the new FLIP4MAC 2.1 (universal) plugin.webplugin → Doesn't recognize WebKit plugin.webplugin format (e.g. new FLIP4MAC 2.1 (universal))
Version: unspecified → Trunk

Comment 6

11 years ago
I do hope to support .webplugin in Gecko 1.9. Might as well use this bug for that purpose.

Updated

11 years ago
Assignee: nobody → joshmoz
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

10 years ago
Duplicate of this bug: 425666

Updated

10 years ago
Summary: Doesn't recognize WebKit plugin.webplugin format (e.g. new FLIP4MAC 2.1 (universal)) → Support WebKit's .webplugin plugins

Comment 8

10 years ago
Update on my really optimistic timeline, I'd say we might do this for whatever comes after the first Mozilla 2 release of Gecko.
If James has offered to write the code now, why wait for the release after the first Mozilla 2 release?

Comment 10

10 years ago
I didn't read all the way through his comment, if he really does follow through on that offer then I'm sure we'd accept the patch. I think it is going to be difficult though, inserting a foreign view is not going to be easy given our current arrangement and neither is getting that working with our plugins module. That said it is doable and my best wishes, I'd be happy to answer questions (after Gecko 1.9 ships).
Okay, excellent.

Updated

9 years ago
Assignee: joshmoz → nobody

Comment 12

5 years ago
I would not take this support even if a patch were available at this point.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.