mail is saved twice to the "sent-folder" (using IMAP)

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
13 years ago
9 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [need protocol log][closeme 2009-09-24])

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

HI!
When thunderbird has a problem with saving a mail to the sent-folder, a small window is shown with the question if the program should try to save the message again. good idea, but sometimes the mail is already saved to the folder.
Would be nice if TB checks if the mail is already in the folder (and does not show the window "try to save,..." or "sending auth. information" for several minutes).

if this is not possible maybe the popup should appear after 1 minute, with the additional information, that one should check if the mail is alraedy saved to the sent-folder.

Reproducible: Always

Comment 1

12 years ago
Hello,

I'm using Seamonkey Mail (Seamonkey 1.1) and sometimes experiencing the same problem with imap accounts. I suppose it's the same problem/technique which has to be changed.
do you still see this problem?
Assignee: mscott → nobody
Whiteboard: closeme 2008-04-31

Comment 3

11 years ago
Hello Wayne,
I`m currently using Seamonkey 1.1.9 and from time to time the problem still appears. Usually with large mail. A few minutes later multiple copies of the sent mail appear in the send box. I assume there is some kind of delay at the mail server.
will need more QA though.
Whiteboard: closeme 2008-04-31 → qawanted

Comment 5

11 years ago
What do you mean with "QA"?
requires more confirmation with additional debug information.
(In reply to comment #3)
> from time to time the problem still appears. Usually with large mail.
> A few minutes later multiple copies of the sent mail appear in the send box.
> I assume there is some kind of delay at the mail server.

Sounds next situation, timeout or connection loss at (a) or (b).
 1. APPEND of sent mail data
 2. IMAP server receives mail data
                                   <== (a) timeout/network-error at client
 3. IMAP returns OK for APPEND
                                   <== (b) timeout at client / network-error
 [ 4. Tb knows OK response for APPEND ] <== doesn't exist 
 5. Because append at step 1 is not completed, Tb requests APPEND again
 6. APPEND successfull, and two copies appear after re-sync.
This is similar to double download of POP3 due to timeout/network error. Difference is direction of mail data flow.
  POP3: POP3 server --> Tb,   IMAP APPEND : Tb --> IMAP server 

To Florian Rittmeier:   
If you can re-produce problem easily, can you get IMAP protocol log with timestamp by DebugView? (if not MS Win, no problem even without timestamp) 
See Bug 402793 Comment #1 and See Bug 402793 Comment #6, please.
See RFC 3501 for IMAP command.
> http://www.faqs.org/rfcs/rfc3501.html

Comment 8

11 years ago
Hello WADA,

I`m using SeaMonkey 1.1.9 on MS Win. What do you mean with DebugView? How can I get it? I would try to provide logs, but don`t know how to configure. I knew it once, but did not find the explanation again.
Read (a) Bug 402793 Comment #1 AND all of bugs/documents pointed in it, please.
Read (b) Bug 402793 Comment #6 AND all of bugs/documents pointed in it, please.
(a) is for getting protocol log(memo not only for you but also for me), and (b) is for getting DebugView & getting NSPR log with DebugView.

Updated

10 years ago
Duplicate of this bug: 366201
Instructions on logging can be found at https://wiki.mozilla.org/MailNews:Logging, could you provide us a log Florian please ?
Keywords: qawanted
Whiteboard: qawanted → [need protocol log]
Whiteboard: [need protocol log] → [need protocol log][closeme 2009-09-24]

Comment 12

10 years ago
Have related problem, pop up window says error saving mail to sent folder, then copy of UNFINISHED email appears in Sent folder. Not clear if that copy has in fact been sent. Using IMAP server for emails. This has been happening since the latest auto update version of TB. Tried installling last overnight build (Sept 1), but the problem persists. REK

Comment 13

10 years ago
Addendum to comment 12: When I cancel the popup, because I do not want to send it to "Sent" folder since I am not finished writing it yet, I get a pop up saying that it could not save my message to drafts folder. REK

Comment 14

10 years ago
Addendum to comment 12: I am also using TB version 2.0.0.24pre (20090901) on a Windows 64 bit.
(In reply to comment #12)
> Have related problem, pop up window says error saving mail to sent folder, then
> copy of UNFINISHED email appears in Sent folder.

RKopacz, do you set up "Drafts" folder correctly? ("Drafts" exists? accessible?) Do you enable auto-save?

Tb currently falls back to "Sent" if saving draft to "Draft" fails. In this case, it confusing but Tb sometimes says "Send error, error on Sent folder" upon draft save error, and falls back to "Sent" folder".

Comment 16

10 years ago
I'm sorry, I cannot provide a log as I switched to TB2 a few months before and haven't seen that problem since then.

Comment 17

10 years ago
Regarding Comment 12, it seems as though the problem is solved. There was something quirky in the way I was subscribed to folders. I unsubscribed and re-subscribed, and the problem seemed to resolve itself. I also had unused folders on the email server which I deleted, this also seemed to help somehow. Thx very much for input and feedback.
WFM per comment 17, ICOMPLETE per comment 16. Closing INCOMPLETE
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Keywords: qawanted
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.