ads through google have an extra / in the URL in camino (not in firefox, etc.) that make them 404's

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
13 years ago
13 years ago

People

(Reporter: edpizzi, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060214 Camino/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060214 Camino/1.0

For example, I clicked on a tripadvisor ad, and got this url:
http://www.google.com//url?q=http://www.tripadvisor.com/%3FSEM-GTEST1223779.html&sa=L&ai=BcfkuRM3UROSKLcTSaJ3fgJEOud_MGbGPl7EC677xCLDMCwgAEAIYAigCOABIpTlQzofqtv3_____AZgB0I8GqgEEMkdNTMgBAZUCBEUaCsgCvf4w&client=&sig=__aDFFQTAR6BlixN7w3377gLI_bzg=

It's valid if you remove the second '/' after google.com. This works for me in firefox. Is this a Mozilla problem or a Google problem?

I've saved the HTML in case this was an experiment of some sort. Here's an excerpt:

<div id=tpa2 style="background-color:#e5ecf9;padding:3px;border:1px none #e5ecf9;" onmouseover="ss('go to www.TripAdvisor.com','aw2')" onmouseout="cs()" onclick="ga(this,event)" class=ch><a id=pa2 href=/url?sa=l&ai=BcfkuRM3UROSKLcTSaJ3fgJEOud_MGbGPl7EC677xCLDMCwgAEAIYAigCOABIpTlQzofqtv3_____AZgB0I8GqgEEMkdNTMgBAZUCBEUaCsgCvf4w&q=http://www.tripadvisor.com/%3FSEM-GTEST1223779.html&sig=__HUVca7TsshdoGIx2_UZtA0P1ufw= onmouseover="return ss('go to www.TripAdvisor.com','aw2')" onmouseout="cs()"><b>Hotel Reviews</b></a><br><font size=-1>

And:
function ga(o,e) {if (document.getElementById) {var a = o.id.substring(1); var p = "", r = "", t, f, h;var g = e.target;if (g) { t = g.id;f = g.parentNode;if (f) {p = f.id;h = f.parentNode;if (h)r = h.id;}} else {h = e.srcElement;f = h.parentNode;if (f)p = f.id;t = h.id;}if (t==a || p==a || r==a)return true;document.getElementById(a).href += "&ct=b" + (bdg ? "d" : "g");bdg = 0;top.location.href=document.getElementById(a).href}}

Reproducible: Always

Steps to Reproduce:
1. search on google
2. click on an ad
3. note the extra '/'
Actual Results:  
404: URL has an extra '/'

Expected Results:  
200: URL has one '/' after google.com
This WFM in a recent 18branch nightly.
This looks like a Google problem; it works for me in 1.0.2 as well.

cl
edpizzi, do you still see this if you try a recent nightly?
edpizzi, can you respond to comment 3 please?  (WFM too, btw)
Whiteboard: [closeme 8/27]
(Reporter)

Comment 5

13 years ago
No, I can't even reproduce it with the browser I originally found this with. I'm chalking this up to some sort of experiment, and closing this as unreproducable.

The URL I get now starts differently, as well as not having an extra '/' character:
http://www.google.com/url?sa=L&ai=Buous2P7oRI2dC4qgwAKh7Jh27-fuC4u-x6gB3MXAGdDwMwgAEAIYAigDSJo5UJySuqv4_____wGYAfqFAaoBBDJHTUzIAQGVAg9yUArIAs2nKg&q=http://www.carmax.com/dyn/home.aspx%3Fadcode%3DGOOAW100564%26CMP%3DKNL-3N7X55145686%26HBX_PK%3Dcar%26HBX_OU%3D50%26s%3D0&sig=__Muy8YHIE8_CArjbH_-0fbZrs3gk=

Note that the order of fields has changed.

Ed
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Updated

13 years ago
Status: RESOLVED → VERIFIED
Whiteboard: [closeme 8/27]
You need to log in before you can comment on or make changes to this bug.