updates folder grows to be 12 GIGABYTES large packed with undeletable files

RESOLVED INVALID

Status

()

RESOLVED INVALID
12 years ago
10 years ago

People

(Reporter: ferdynus, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

after about 2 years of using firefox I noticed that the \mozilla\firefox\updates\0 contains over 12 GB of data. 

the folder looks like this: http://img8.picsplace.to/img.php?file=img8/20/error_2_folders.JPG

and to demonstrate the proportions of the space the files inside it take up I used spacemonger.exe to visualise the problem (it also was the program with which I noticed the problem at all when I saw that firefox used so much space on my hard drive xD ) http://img8.picsplace.to/img.php?file=img8/20/error_3_space.JPG

when I tried to enter one of the subfolders in the "0" folder I ended up with an error notification from windows telling me that the data that the folder/path refers to is currently not connected to my pc (as if I had it on a cd that isnt in my drive or on a network folder that is disconnected) (screenshot of the error [sorry its in german x) ] http://img8.picsplace.to/img.php?file=img8/20/error_1.jpg)

when I tried to delete any of the files inside the 0 folder I got the error notification that it cant be deleted because the root-file or the root-drive cannot be accessed [again in german] http://img8.picsplace.to/img.php?file=img8/20/error_4_cant_delete.JPG

as I already said I noticed the problem after two years of using this program so I have no idea at all how to reproduce it. should I ever use firefox again after formatting my harddrive then I'll probably refrain from using the automated updates and simply download the newest version manually.

another possibility could be that those 12 gb of data are "virtual" and my OS just marks them to take up so much space. I'm sorry I cannot be of more assistance. I just wanted to make you aware of the existence of such a problem.

PS: on the bright side I cannot recall firefox crashing my pc at any time :)

have a nice day =)

Reproducible: Didn't try
That looks very much like you have some problems with the disk file system. Have you run the MS disk checker recently ? (Check Now from the Tools tab of the Disk properties). Might save on having to reformat your disk.
Try unlocker ( http://ccollomb.free.fr/unlocker/ ) to get info on what process is locking the files from deletion, and also as to what process is holding onto them.
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> Try unlocker ( http://ccollomb.free.fr/unlocker/ ) to get info on what process
> is locking the files from deletion, and also as to what process is holding onto
> them.
>

thanks for the useful link.

 but the problem is NOT that some unknown program is using the files. instead windows tells me that the DRIVE on which those files are stored is not accessible.

thanks for the good will anyway =)
Already looked into Microsoft's knowledge database?
http://support.microsoft.com/?kbid=320081
quite sure the connection between firefox and the filesystem corruption is purely coincidental. ->i
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.