Go and Search button looks misplaced using classic theme

RESOLVED FIXED in Firefox 2

Status

()

Firefox
General
RESOLVED FIXED
12 years ago
7 years ago

People

(Reporter: José Jeria, Assigned: mconnor)

Tracking

({fixed1.8.1, polish})

2.0 Branch
Firefox 2
x86
Windows XP
fixed1.8.1, polish
Points:
---
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Fx2 theme change])

Attachments

(3 attachments)

(Reporter)

Description

12 years ago
Thhe go and search button looks odd and misplaced using Windows XP with the classic theme. 

See attached animated gif for comparison
(Reporter)

Comment 1

12 years ago
Created attachment 232412 [details]
Screenshot (animated)
*** Bug 347637 has been marked as a duplicate of this bug. ***

Comment 3

12 years ago
*** Bug 347637 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

12 years ago
Keywords: polish

Comment 4

12 years ago
I believe there are multiple separate issues to this bug:

1. The location bar is taller than the go button when using Windows Classic Style, causing the Go button not to line up with it.

2. The border around the Go and Search buttons is part of the graphic, rather than using native controls.  The border looks inconsistent when using Windows Classic Style.

3. The colors of both the Go and Search buttons have been designed to complement the Windows XP Style default colors, and are less suitable for other colours, such as the Windows Classic Style grays.

Highest priority would be 1, followed by 2, followed by 3.  Personally, I don't particularly mind 3.

Suggestions for fixes, respectively:

1. Reduce the height of the location bar when viewed in Windows Classic Style.  Or, design the Go button so that its height scales to the size of the bar.

2. Design the Go and Search buttons in such a way as the border around them matches the appearance of the borders around the location and search bars.  If possible, use the same appearance as the native controls.

3. Use alpha transparency on the Go and Search buttons to ensure that the background color is substantially derived from the color of the toolbar itself, rather than assuming the color of the toolbar will be consistent across different environments.

Comment 5

12 years ago
Created attachment 232488 [details]
Demonstration of problem #1 (see comment #4)

Comment 6

12 years ago
*** Bug 347751 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

12 years ago
Assignee: nobody → mconnor
Flags: blocking-firefox2+
Whiteboard: [Fx2 theme change]
(Assignee)

Comment 7

12 years ago
To people using Classic, how does this look with the new transparent button?

Comment 8

12 years ago
Created attachment 233718 [details]
screenshot after transparent buttons

(In reply to comment #7)
> To people using Classic, how does this look with the new transparent button?

It solves problem 3 in comment #4.  It looks better in terms of colour.  Problems 1 and 2 remain.
Target Milestone: --- → Firefox 2

Comment 9

12 years ago
(In reply to comment #8)
> It solves problem 3 in comment #4.  It looks better in terms of colour. 
> Problems 1 and 2 remain.

Problem 1 is bug 348138.

Problem 2 may be solved by bug 347616, which itself probably depends on a solution like bug 348138.
(Assignee)

Comment 10

12 years ago
Discussed with beltzner, 1 and 2 are not going to change at this point, resolving fixed.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Assignee)

Updated

12 years ago
Keywords: fixed1.8.1
You need to log in before you can comment on or make changes to this bug.