skins/custom/*.css not created

RESOLVED FIXED in Bugzilla 3.0

Status

()

Bugzilla
Installation & Upgrading
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Frédéric Buclin, Assigned: Max Kanat-Alexander)

Tracking

({regression})

2.23
Bugzilla 3.0
regression
Bug Flags:
approval +

Details

Attachments

(1 attachment)

v1
767 bytes, patch
Frédéric Buclin
: review+
Details | Diff | Splinter Review
(Reporter)

Description

12 years ago
I did a fresh install yesterday, and my apache error log is full of messages of the form:

File does not exist: /var/www/html/bugzilla-pg/skins/custom/index.css
File does not exist: /var/www/html/bugzilla-pg/skins/custom/global.css

Running checksetup.pl again and again doesn't help, these files are still missing. the skins/custom directory exists, but remains empty.
(Assignee)

Comment 1

12 years ago
Yep, you're right. I'll look into it.
(Reporter)

Comment 2

12 years ago
*** Bug 348549 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

12 years ago
Look at bug 348549 comment 0 for a possible explanation of the problem.
(Assignee)

Comment 4

12 years ago
Created attachment 233591 [details] [diff] [review]
v1

Ah, very simple. I see what happened. When I moved the permission-fixing code, I just forgot to fix this one line.
Assignee: installation → mkanat
Status: NEW → ASSIGNED
Attachment #233591 - Flags: review?(LpSolit)
(Reporter)

Comment 5

12 years ago
Comment on attachment 233591 [details] [diff] [review]
v1

r=LpSolit
Attachment #233591 - Flags: review?(LpSolit) → review+
(Reporter)

Updated

12 years ago
Flags: approval?
Flags: approval? → approval+
(Assignee)

Comment 6

12 years ago
Checking in Bugzilla/Install/Filesystem.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Install/Filesystem.pm,v  <--  Filesystem.pm
new revision: 1.9; previous revision: 1.8
done
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.