highlight of selected images extends too much to the top and left

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: Uri Bernstein (Google), Unassigned)

Tracking

({regression, testcase})

Trunk
PowerPC
Mac OS X
regression, testcase
Points:
---
Bug Flags:
blocking1.9 -
wanted1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
When an image is selected, the highlighted rectangle is usually too large - extending to the left and top of the image. This happens in a non totally predictable way: the same image might have a different highlighted area depending (in a non-straightforward way) on its surroundings.  

This regressed between 2006-01-25 and 2006-01-26, likely due to bug 317375.

I'll attach a testcase immediately.
(Reporter)

Comment 1

12 years ago
Created attachment 232433 [details]
testcase

The margins on the images aren't necessary for the bug to show - they just help see what's going on by preventing the highlights from overlapping.
(Reporter)

Comment 2

12 years ago
Created attachment 232434 [details]
screenshot of testcase
(Reporter)

Updated

12 years ago
Flags: blocking1.9?
Keywords: testcase
Are you going to fix this or am I? :-)
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> Are you going to fix this or am I? :-)

Probably you, unless you give me some good hints where to start looking. I never dealt with highlighting code before.
That code is right here
http://lxr.mozilla.org/seamonkey/source/layout/generic/nsFrame.cpp#779

I'm always happy to give hints :-)
Flags: blocking1.9? → blocking1.9-
Whiteboard: [wanted-1.9]
(Reporter)

Comment 6

11 years ago
This WFM since 2006-11-22, that is, since the switch to cairo (bug 323934).
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Flags: wanted1.9+
Whiteboard: [wanted-1.9]
You need to log in before you can comment on or make changes to this bug.