monospace font pref being 'monospace' makes monospace fonts non-monospace

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: dbaron, Unassigned)

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

In at least some recent Linux desktop environments (such as Fedora Core 5), the default monospace font on the system is called "monospace" (which is really an alias to another font).  However, in cairo-enabled builds, choosing this as the default monospace font in font preferences leads to fonts that should be monospaced using the default non-monospaced font.

Steps to reproduce:
 * In Firefox, go to Edit -> Preferences -> Content -> Fonts & Colors -> Advanced... -> Monospace
 * set the monospace font to "monospace"
 * load this bug report

Actual results: bug comments and textarea are in proportional font

Expected results: bug comments and textarea in monospaced font

(I thought I filed this back when cairo was turned on, and I may have even sent vlad mail at the time about what the underlying cause was, but I can't find either.)
Is this bug also what is causing e.g. bugmail to look like crap in thunderbird trunk builds? (It seems a proportional font is used, I'm on ubuntu edgy.)
Flags: blocking1.9? → blocking1.9+
Version: 1.8 Branch → Trunk
Target Milestone: --- → mozilla1.9alpha6
See bug 324706. All it's testcases fail for me on Windows. I too remember seeing non-monospace text all over the place where it should be monospace on Linux some days ago.
I can't reproduce this under ubuntu feisty; I get monospace text.  But I think a lot of this depends on the exact set of fonts installed.
FWIW, I'm now on ubuntu feisty too and I don't get correct monospace text.
punting remaining a6 bugs to b1, all of these shipped in a5, so we're at least no worse off by doing so.
Target Milestone: mozilla1.9alpha6 → mozilla1.9beta1
If you are able to reproduce this with the monospace font set to "monospace", are you able to attach a log from a run with FC_DEBUG=3 in the environment, viewing this bug (or a small problem page) and quiting, please?
After setting monospace font to "monospace" I don't have this problem anymore. It showed as being set to the first available font in the list - nothing I had changed myself though... The thunderbird problem went away with bug 386389.
(In reply to comment #7)
> It showed as being set to the first available font in the list - nothing I had
> changed myself though...

You may be interested in bug 379886.
(In reply to comment #6)
> If you are able to reproduce this with the monospace font set to "monospace",
> are you able to attach a log from a run with FC_DEBUG=3 in the environment,
> viewing this bug (or a small problem page) and quiting, please?

OK, FC_DEBUG=3 is probably going to produce too much output to attach here, especially if you have many fonts installed.  FC_DEBUG=1 should be good enough.

Updated

11 years ago
Priority: -- → P3
(In reply to comment #9)

Or even a simple "fc-match -v monospace" may be helpful.

Updated

11 years ago
Target Milestone: mozilla1.9 M8 → ---

Comment 11

11 years ago
dbaron? are you still seeing this?
Works for me in 2007-10-24-04-trunk Linux nightly but it also works for me in 2006-08-09-04-trunk Linux nightly, which means that I've upgraded my system since filing this such that I no longer see it, not necessarily that the bug was (or wasn't) fixed.  So you should ask one of the other people who was seeing it.

Comment 13

11 years ago
so, i think this is gone and/or newer distros have fixed themselves.

please reopen if anyone can reproduce and explain whats going up (running the stuff karlt suggests above)
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.