If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Unifinder: Multiple selection with Shift + Up/Down doesn't work as expected

VERIFIED WORKSFORME

Status

Calendar
Calendar Views
--
minor
VERIFIED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Damian Szczepanik, Unassigned)

Tracking

Trunk
x86
Windows XP

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060807 Calendar/0.3a2+

You can not select more than two events in unifinder when you use SHIFT + DOWN

Reproducible: Always

Steps to Reproduce:
1. have at least 3 events and make sure that you can see all of them (resize unifinder if need)
2. select first event in unifinder
3. push SHIFT (do not release)
4. press DOWN to select another event
5. repeat step four few times
   -> only two last events are selected
6. you can not do the same with last event, SHIFT and UP button - UP button does not work

Actual Results:  
only two events are selected

Expected Results:  
first selected event should not be modified, only last one

JS console is empty
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk
Confirmed. Additionally, you cannot select more than the initially selected event with Shift + Up.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: unifinder: when push SHIFT and press down only two events are selected → Unifinder: Multiple selection with Shift + Up/Down doesn't work as expected

Updated

11 years ago
Depends on: 348481

Comment 2

11 years ago
WORKSFORME probably because of checking in bug 321384. Dependancy seems to be wrong, since bug 348481 is still valid.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

11 years ago
yes, now works properly

verified with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060908 Calendar/0.3a2+
Status: RESOLVED → VERIFIED
(Reporter)

Updated

11 years ago
Whiteboard: [litmus testcase wanted]
(Reporter)

Comment 4

11 years ago
Litmus testcase 2636 created
Whiteboard: [litmus testcase wanted]
You need to log in before you can comment on or make changes to this bug.