[Mac] Tabs aligned to the left when they should be centered

RESOLVED FIXED in Firefox 2 beta2

Status

()

P1
normal
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: mark, Assigned: mano)

Tracking

({fixed1.8.1, regression})

2.0 Branch
Firefox 2 beta2
PowerPC
Mac OS X
fixed1.8.1, regression
Points:
---
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
Spun off from bug 347533: native-theme tabs should be centered to match the native look and feel on the Mac.  They are now aligned to the left.  This is a regression from 1.5.  Screenshot at attachment 232335 [details] (that screenshot from bug 347533 also shows bug 347533, a vertical gap between the tabs and the horizontal bar.)
(Reporter)

Updated

12 years ago
Flags: blocking-firefox2?
OS: Mac OS X 10.3 → Mac OS X 10.2
(Reporter)

Comment 1

12 years ago
Testcase: Tools:Page Info and Firefox:Preferences:Advanced.  The tabs in Firefox:Preferences:Advanced:Encryption:View Certificates are properly centered.
FWIW, the regression (on trunk) was between 2006-04-13 and 2006-04-14.
I can't find an obvious candidate for what broke this.
(Reporter)

Comment 3

12 years ago
Thanks, Uri.  Also, note that the background in the Page Info window is white, when it should be a reasonable striped gray.  That regression occurred at the same time that the tabs shifted.

Regressed between 041304 and 041405 (trunk) and 041313 and 041403 (1.8):

http://bonsai.mozilla.org/cvsquery.cgi?branch=HEAD&branchtype=match&date=explicit&mindate=2006-04-13+01%3A00&maxdate=2006-04-14+06%3A00
http://bonsai.mozilla.org/cvsquery.cgi?branch=MOZILLA_1_8_BRANCH&branchtype=match&date=explicit&mindate=2006-04-13+10%3A00&maxdate=2006-04-14+04%3A00

Looks to me like bug 333863.

(...checking...)

Yup, that's it.  This line looks suspicious:

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/browser/base/content/macBrowserOverlay.xul&rev=1.9&mark=54#43

Mano, did you intend to reference a stylesheet there, or should we just remove that line?
Blocks: 333863
Taking.
Assignee: nobody → bugs.mano
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → Firefox 2 beta2

Updated

12 years ago
Flags: blocking-firefox2? → blocking-firefox2+
Whiteboard: [Fx2 theme change]
Created attachment 233212 [details] [diff] [review]
Don't load browser.css

This _may_ regress places on trunk. If it turns out that's the case, I'll address it in a separate bug.
Attachment #233212 - Flags: review?(mconnor)
Whiteboard: [Fx2 theme change]

Updated

12 years ago
Attachment #233212 - Flags: review?(mconnor) → review+
Whiteboard: [Fx2 theme change]
Target Milestone: Firefox 2 beta2 → Firefox 2
Whiteboard: [Fx2 theme change]
Target Milestone: Firefox 2 → Firefox 2 beta2
Checking in browser/base/content/macBrowserOverlay.xul;
/cvsroot/mozilla/browser/base/content/macBrowserOverlay.xul,v  <--  macBrowserOverlay.xul
new revision: 1.10; previous revision: 1.9
done
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Comment on attachment 233212 [details] [diff] [review]
Don't load browser.css

a=drivers for MOZILLA_1_8_BRANCH
Attachment #233212 - Flags: approval1.8.1? → approval1.8.1+
1.8 branch: Checking in browser/base/content/macBrowserOverlay.xul;
/cvsroot/mozilla/browser/base/content/macBrowserOverlay.xul,v  <--  macBrowserOverlay.xul
new revision: 1.7.8.3; previous revision: 1.7.8.2
done
Keywords: fixed1.8.1
You need to log in before you can comment on or make changes to this bug.