Duplicate entry DB error when recreating component with same name as deleted component

RESOLVED DUPLICATE of bug 247936

Status

()

--
minor
RESOLVED DUPLICATE of bug 247936
12 years ago
12 years ago

People

(Reporter: kunalzilla, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Bugzilla 2.22

Creating a component that has the same name as a previously deleted component causes the following error to appear. Note: the component still gets created.

DBD::mysql::db do failed: Duplicate entry '204-7-9-All Open' for key 2 at Bugzilla/Series.pm line 201
	Bugzilla::Series::writeToDatabase('Bugzilla::Series=HASH(0x9b81514)') called at editcomponents.cgi line 211



Reproducible: Always

Steps to Reproduce:
1. Create a component, i.e. "xyz"
2. Delete this component.
3. Create a component again with the same name, "xyz"




This error does not occur when renaming a bug through the edit component interface, which means a very easy work-around is to create a component with an arbitrary name, then rename it to what you want.

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 247936 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.