an html element (map) is not working right

VERIFIED WORKSFORME

Status

()

P3
major
VERIFIED WORKSFORME
19 years ago
17 years ago

People

(Reporter: assaf, Assigned: buster)

Tracking

({helpwanted})

Trunk
x86
Windows NT
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; N; WinNT4.0; en-US; m14) Netscape6/6.0b1
BuildID:    2000032306

When i choose from the menu on the upper right screen (action, adventure etc.) I
end up in http://www.gamespot.com/shared/genrebuttons_0898.map. it looks like
the coordinates are not updated properly.

Reproducible: Always
Steps to Reproduce:
1.goto http://www.gamespot.com
2.click on "action" from the upper right menu
3.


Actual Results:  you end up in
http://www.gamespot.com/shared/genrebuttons_0898.map and have to choose again

Expected Results:  you should go directly to "action"

Comment 1

19 years ago
Yeah, confirming. But note that the image appears middle-left, which is a
rendering bug (I guess), it is no-where near top-right of the page. Linux build
from tree 2000-04-06.

Comment 2

19 years ago
Confirming both bugs -- the image map bug, and the image position bug. These
should really be two separate bug reports.

One curious thing is the co-ordinates of the image map remain 0,0 until around
the top of the "Hardware" button. From that point downwards, only the vertical
co-ordinate updates.

This is on the 2000040616 build on NT 4 Workstation, SP5.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

19 years ago
Pushing this to buster to address the image placement issue.
Assignee: rickg → buster
(Assignee)

Comment 4

19 years ago
won't have a chance to look at this for a few weeks, setting to M17.  Marking 
"helpwanted" because a simplified test case (minimized HTML source that exhibits 
the bug) would go a long way towards getting this fixed sooner.
Status: NEW → ASSIGNED
Keywords: helpwanted
Target Milestone: --- → M17

Comment 5

19 years ago
With the May 01 build, clicking on the image map is working for me. All the links 
assigned to image areas are working.
nsbeta2 6/1-. HTML 3.2 image maps. But may be fixed. Emailed asking reporters to 
confirm.
Keywords: nsbeta2
(Assignee)

Comment 7

19 years ago
with a recent build, this seems to work fine.  They've changed their site a bit, 
the menu is now down on the left edge.  In the future, if you find a page that's 
broken, it would be a big help to use the browser to save the page to disk, then 
upload it as part of the bug report.  Submit the bug, then click on the 
"Create a new attachment" link in the bug report.  That way, if a site changes, 
we still have the original data.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 8

18 years ago
massive update for QA contact.
QA Contact: petersen → lorca

Comment 9

18 years ago
Works for me:
Platform: PC
OS: Windows 98
Mozilla Build: 2000101014 M18 Trunk Build

Marking as Verified.
Status: RESOLVED → VERIFIED
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.