Closed Bug 347843 Opened 14 years ago Closed 10 years ago

"automatically do this" ticked but "what should firefox do?" dialog still displayed

Categories

(Firefox :: File Handling, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 453455

People

(Reporter: mozilla, Unassigned)

References

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

So I click on a link to a .torrent file.
I've got Azuerus installed and so my system has a mime handler for these files.
I choose "open with azuerus" and also tick the "automatically do this from now on".
The bug is that I always get the dialog, even though I ticked the check-box that should mean I do not get the dialog.

Reproducible: Always

Steps to Reproduce:
1. Click on a link to a torrent file
2. Choose open with Azuerus
3. Tick check box for this action to be done automatically
4. Click OK
5. Try another torrent file
Actual Results:  
dialog opens again

Expected Results:  
no dialog
Even though it seems like, and may well be, "every single one," please give us one particular link that doesn't work for you.

Also, could you please attach the file mimeTypes.rdf from your profile folder? (http://kb.mozillazine.org/Profile_Folder will tell you where to find it).
Component: Download Manager → File Handling
QA Contact: download.manager → file.handling
Summary: "automaticall do this" ticked but "what should firefox do?" dialog still displayed → "automatically do this" ticked but "what should firefox do?" dialog still displayed
as requested
Comment on attachment 232874 [details]
mimeTypes.rdf from my profile folder

Easier to see as text/plain
Attachment #232874 - Attachment mime type: application/rdf+xml → text/plain
Since both those links are sent as application/x-bittorrent, I can't blame it on the usual, misconfigured servers using random content types.

However, that's an interesting mimeTypes.rdf, despite it being empty. I don't remember ever seeing that long chatty comment. Are you absolutely certain that's from the Firefox profile you are currently using? And do you know where it came from, migrating from something else like the suite, or from starting your profile in some particular version of Firefox/Firebird/Phoenix? And is there anything odd about the file in the filesystem, like it's marked as being read-only?
The steps to reproduce even apply on a clean profile with the latest Bon Echo nightly (2006080903).
Status: UNCONFIRMED → NEW
Ever confirmed: true
It looks like the URLs in question are delivered with a Content-Disposition: attachment HTTP header.  This forces Firefox to prompt the user despite having been told previously what to do with certain types of files (which, IMO, is broken behavior).  See bug 236541 and bug 315536 for more information.  Interestingly, both bugs are marked as FIXED but this problem seems to persist.  I'm still running 1.5 so I can't test this, but I thought I'd point this out to hopefully help identity the problem.
I get the same error.  I use Bittorrent.
This problem exists for files as simple as JPGs. When I receive an email with a JPG attachment, and I click on either the thumbnail OR the file name, and even though I had previously checked "Do this automatically for file like this from now on" (and had even restarted Firefox), it still aways opens that dialog box and asks again "Do this automatically..."  It never remembers.
This has existed at least since 3.0.10, but I just checked it in Beta 4, and it still exists. 6/08/09 6:30 PM.
This problem exists for files as simple as JPGs. When I receive an email with a JPG attachment, and I click on either the thumbnail OR the file name, and even though I had previously checked "Do this automatically for file like this from now on" (and had even restarted Firefox), it still aways opens that dialog box and asks again "Do this automatically..."  It never remembers.

This has existed at least since 3.0.10, but I just checked it in Beta 4, and it still exists. 6/08/09 6:30 PM.
Duplicate of this bug: 431876
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 453455
You need to log in before you can comment on or make changes to this bug.