Closed Bug 347987 Opened 15 years ago Closed 14 years ago

FAYT-bug: reproduceable way to make it show

Categories

(Toolkit :: Find Toolbar, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: teoli, Unassigned)

References

Details

(Whiteboard: CLOSEME 08/08)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

The FAYT-bug is probably trigerred by several things. It never show at my place, except if I do the following steps. In that case it appears.

Reproducible: Always

Steps to Reproduce:
1.In a textarea, type some text
2.Do a CTRL-F to start a search
3.Quit the find toolbar by hitting ESC (not by closing it with the cross)
4.(You are again in the text area)
5.Press ' 
Actual Results:  
The find toolbar opens.

Expected Results:  
A ' should have been inserted

(Sorry to open a new bug, but among the numerous reports of FAYT-bug with UNCONFIRMED, I was unable to find the right one to add this)
Blocks: findgrabs
On Mac trunk, pressing Cmd+F and then Esc seems to remove focus from the textarea completely.
(In reply to comment #1)
> On Mac trunk, pressing Cmd+F and then Esc seems to remove focus from the
> textarea completely.
> 
Sometimes I get the focus back in the textarea, and the bug happens.
Sometimes I do not get the focus back in the textarea, and the bug, of course, doesn't happen.

I'm trying to find more precise conditions.
What site did this happen on? Maybe they're focusing the textarea with JS or something.
(In reply to comment #3)
> What site did this happen on? Maybe they're focusing the textarea with JS or
> something.
I was reproducing it with forums.mozillazine.org and www.geckozone.org (the french equivalent of mozillazine.org). So I don't think that's the point.

Since then, I'm unable to reproduce it again. I'm still trying to find a more precise use case. The ESC point rather than the cross was important while I was able to reproduce it, but there must be a second event that I didn't grasped, yet.

Did you have more than one firefox window open?
Reporter, have you been able to reproduce this in a more recent version of Firefox? 

This Worksforme in Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a7pre) Gecko/2007072404 Minefield/3.0a7pre
Whiteboard: CLOSEME 08/08
WFM per comment 6
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → WORKSFORME
Sorry for the delay. No, I didn't see this again since a long time. I already put the bug as RESOLVED WORKFORME. Should I set it to FIXED?
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.