Closed Bug 348047 Opened 14 years ago Closed 11 years ago

[10.5] need to add 512x512 icon to Firefox icon file

Categories

(Firefox :: Shell Integration, defect, P4, major)

All
macOS
defect

Tracking

()

RESOLVED FIXED
Firefox 3 beta3

People

(Reporter: jaas, Assigned: faaborg)

References

Details

Attachments

(1 file)

Mac OS X 10.5 will make use of 512x512 application icons in some cases. We should add a 512x512 icon to the Firefox icon file.
(Why doesn't Apple just let you supply an icon in some vector format?  Top-notch PDF support...)
Blocks: 348059
There already is one. Not in icns format, but it can be converted.

http://www.graphicsguru.com/mozilla.php

It's by a member of Mozilla. I think.
We should do this soon and add it to the Firefox 2 branch as well since Mac OS X 10.5 is a few months away. We can't support full resolution independent UI with Firefox 2, but we don't have to have a pixelated application icon.

I don't know how we go about getting official Firefox logo artwork done for the tree. Any pointers about who to contact would be great.
Severity: normal → major
Link again:http://www.graphicsguru.com/mozilla.php

Think person is part of mozilla, not sure.
Admin/Mod username "Jamie" of SpreadFirefox
I have the original ai files for the Firefox logo, we are now checking with Silver Orange to see if there were any changes made when producing the icons.

What is that graphicsguru link?  Does anyone know if we put those up?
Keywords: uiwanted
Jamie is a volunteer admin for Spread Firefox, and a longtime Mozilla marketing contributor. Adding Steven Garrity from Silverorange, cbeard and asa.
This should block Firefox 3 as Firefox 3 will almost certainly be released well after Mac OS X 10.5.
Flags: blocking-firefox3?
Flags: blocking-firefox3? → blocking-firefox3+
Target Milestone: --- → Firefox 3 beta1
All of the following files need updated (bigger) icons, I will post the most important ones soon.

/toolkit/mozapps/update/src/updater/macbuild/Contents/Resources/updater.icns
/toolkit/airbag/client/macbuild/Contents/Resources/crashreporter.icns
/browser/branding/unofficial/document.icns
/browser/branding/unofficial/firefox.icns
/browser/branding/unofficial/disk.icns
/browser/app/macbuild/document.icns
/browser/app/macbuild/firefox.icns
/browser/app/macbuild/disk.icns
/other-licenses/branding/firefox/document.icns
/other-licenses/branding/firefox/firefox.icns
/other-licenses/branding/firefox/disk.icns
This file was updated using official Mozilla artwork and IconComposer on the Mac OS X 10.5 beta. IconComposer on the 10.5 beta is the first version capable of adding 512 and 256 icons.
Assignee: nobody → joshmoz
Status: NEW → ASSIGNED
Attachment #269039 - Flags: review?(cbarrett)
we need to remove the (r), it looks like a smudge and isn't in the current icons.  Also, the 16x16 version should be the pixel art icon, not a scaled down version of the source artwork.
The 16x16 is the pixel art version I think because I left that alone.
Comment on attachment 269039 [details]
/other-licenses/branding/firefox/firefox.icns - v1.0

Looks good. Looks fine in Cover Flow. 

I'm assuming the little (c) in the bottom right is supposed to be there? It's much more noticable at high resolutions, perhaps it should be scaled down a bit? Other than that, it's fine.
Attachment #269039 - Flags: review?(cbarrett) → review+
Per Catherine Brady, the correct legal mark on the Firefox logo is a little TM symbol. Although it's in the process of becoming a registered trademark, the only Firefox logo that currently gets the (r) is the wordmark.

However, she also indicated that in some special cases, including icons, it would be ok to remove the TM symbol. Ideally there would be some legal text at the bottom of the page explaining its trademark status, but if that's not possible it's ok to go without if it's a software icon.

Long story short, it's ok to go without the symbol in this. But for future reference in other projects, it should be a TM.
So I guess I'll not try to land that icon and wait until I can remove that (c).
Target Milestone: Firefox 3 M7 → Firefox 3 M9
Target Milestone: Firefox 3 M9 → Firefox 3 M10
Summary: need to add 512x512 icon to Firefox icon file → [10.5] need to add 512x512 icon to Firefox icon file
Whiteboard: [need updated icon]
Target Milestone: Firefox 3 M10 → Firefox 3 M11
Priority: -- → P4
-> nobody, somebody that does graphics/UI can do a better job with this than me

The "Icon Composer" app that is installed with Xcode 3 on Mac OS X 10.5 is what can make the new icon file that supports 512x512 icons.
Assignee: joshmoz → nobody
Status: ASSIGNED → NEW
Just a heads up that we've contracted Jon Hicks to refresh the Firefox icon, so he will be delivering new files with the correct resolutions, there is no need for us to work on it.
Assignee: nobody → jon
removing uiwanted since we are currently in the process of making the icon.
Keywords: uiwanted
Not going to continue to block on this.  If you disagree with this decision, please renominate with reasons why we can't ship with this in final
Flags: wanted-firefox3+
Flags: blocking-firefox3-
Flags: blocking-firefox3+
Duplicate of this bug: 437374
Duplicate of this bug: 440942
Flags: wanted-firefox3.1+
btw: the .dmg file, the document.icns, Crash Reporter, Updater needs a higher res icon too.
>btw: the .dmg file, the document.icns, Crash Reporter, Updater needs a higher
>res icon too.

Thanks for the heads up, I've added all of those to the inventory for 3.1
Assignee: jon → faaborg
Whiteboard: [need updated icon] → [need updated icon][icon-3.1]
Whiteboard: [need updated icon][icon-3.1] → [icon-refresh][icon-3.1]
This will be fixed indirectly by bug 492431 with a whole new app icon on OS X
Whiteboard: [icon-refresh][icon-3.1] → [icon-refresh][icon-shiretoko]
Depends on: 492431
Whiteboard: [icon-refresh][icon-shiretoko]
Is this fixed now that bug 492431 is fixed?
Hardware: PowerPC → All
>Is this fixed now that bug 492431 is fixed?

yep
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.