Closed Bug 34814 Opened 23 years ago Closed 23 years ago

Netscape 6 ignoring COL attributes

Categories

(Core :: Layout: Tables, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED DUPLICATE of bug 915

People

(Reporter: paul.hardaker, Assigned: karnaze)

Details

I have created the following HTML:

<HTML>
<HEAD>
</HEAD>
<BODY>
<DIV style="overflow:hidden;height:150px;width:100%;background-
color:lightgreen">
<DIV style="overflow:scroll;">
<TABLE style="border: thin black solid">
<THEAD>
<COLGROUP>
<COL align='right'>
</COLGROUP>
</THEAD>
<TBODY>
<TR><TD>testxxxxxxxxxx</TD></TR>
<TR><TD>test</TD></TR>
<TR><TD>test</TD></TR>
<TR><TD>testxxxxx</TD></TR>
<TR><TD>test</TD></TR>
<TR><TD>test</TD></TR>
<TR><TD>testxxxxxxxxxxxx</TD></TR>
<TR><TD>test</TD></TR>
<TR><TD>test</TD></TR>
<TR><TD>test</TD></TR>
</TBODY>
</TABLE>
</DIV>
</DIV>
</BODY>
</HTML>

There are 2 problems. Firstly, the align='right' attribute of the COL is being 
ignored. 

Secondly, I expect the inner DIV to get scroll bars, but currently assigning 
overflow:scroll causes the inner DIV to stretched to fit the content of the 
TABLE, when I expect the outer DIV to restrict the size.
You really should test bugs of mozilla, not netscape 6 to bugzilla. Read the 
guildlines in bugzilla.
Anyhow this is a duplicate of an old bug, that they are still working on, bug 
#915

*** This bug has been marked as a duplicate of 915 ***
Status: UNCONFIRMED → RESOLVED
Closed: 23 years ago
Resolution: --- → DUPLICATE
Is this really a dup of bug #915? Bug #915 is dealing with the CSS 'text-align' 
property. This bug deals with the 'align' HTML attribute. In the content of bug 
#915, it appears that there is some question as to whether in this case the 
HTML attribute should be mapped to the CSS property. If they are not mapped 
together, then there should be two separate bugs.
Adding keyword 'verifyme' to bug.
Keywords: verifyme
Verified dup of #915
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.