Continuously loading page if img width=x% and image partially covered

VERIFIED WORKSFORME

Status

()

P3
normal
VERIFIED WORKSFORME
19 years ago
18 years ago

People

(Reporter: richardbiddle, Assigned: troy)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-US; m14)
BuildID:    2000040108

Page loads continously when img width is set.  Can reproduce bug in one line
html file:
<img src="imgbug.gif" width=50%>
if the window is too short to show all of the image.  Occasionly loads ok but
after resize and reload the bug always happens again.



Reproducible: Always
Steps to Reproduce:
1.Make window short
2.Open page containing <img width=x%...



Actual Results:  The page looks fine but it never completes loading.
Must press stop.  And noted "Document:Done(22.45 secs)" or however long you wait
before stopping.
One result is it doesn't load javascript 'onload' scripts.


Expected Results:  Stopped loading.
Run 'onload' scripts.


It happened with gifs and jpgs.
One line html file shows the bug:
<img src="imgbug.gif" width=50%>
If you can't reproduce the bug, resize then reload, try and cover part of the image.
(Reporter)

Comment 1

19 years ago
Created attachment 7308 [details]
An html file showing bug
(Assignee)

Comment 2

19 years ago
I can't reproduce this. It works fine for me with the latest build. The page 
doesn't continuously load
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 3

18 years ago
Works for me:
Platform: PC
OS: Windows 98
Mozilla Build: 2000101014 M18 Trunk Build

Marking as Verified.
Status: RESOLVED → VERIFIED

Comment 4

18 years ago
I'm still getting a loop loading of an image in a table when %-width is 
specified. I'm running Mozilla 0.7 (Build 2001010901) on Win95. I can reproduce 
this every time with this sample code :
("dot.gif" is a simple 1x1 image)

<html>
<body>

<!-- Image ok -->
<img src="dot.gif" height=50 width=100%>

<table width=100% border=1>
<tr>
	<td>
		<!-- Image continously loading and blinking -->
		<img src="dot.gif" height=50 width=100%>
	</td>
</tr>
</table>

</body>
</html>
You need to log in before you can comment on or make changes to this bug.