Open Bug 348187 Opened 15 years ago Updated 5 years ago

typeaheadfind.autostart not respected

Categories

(Toolkit :: Find Toolbar, defect, P5)

defect

Tracking

()

People

(Reporter: mikel, Unassigned)

References

()

Details

In the Firefox 2.0 beta (build 20060710) on Windows, typing inside a web page automatically starts type ahead find, even if the autostart preference is false.

This makes it impossible to use the QuirksMode keyboard test page.

To reproduce:
1) set accessibility.typeaheadfind = true
       accessibility.typeaheadfind.autostart = false
2) open the linked page
3) click inside the document body (but outside the text/list box)
4) type 'a' on the keyboard

Actual results:
New findahead bar appears with 'a' in the search field

Expected results:
The 'a' keystroke is made available to the page's script
(and the corresponding keycode is listed in the box if the script on the linked works!)
Should have made it clear.  I just meant pressing the single <a> key on the keyboard, without the quotes. :-)
Obviously for the key events to appear in the list box, you would need to tick "Switch key events on/off" on the linked page first.  The bug still exists in any case, that just clarifies the steps to reproduce.

The type ahead find bar appears down the bottom of the window with the text "Quick Find:".  I think this is new since the Firefox 1.5 release/branch.  I don't think I had this problem using Firefox 1.5 on Linux.
See http://kb.mozillazine.org/Accessibility.typeaheadfind.autostart.

*** This bug has been marked as a duplicate of 254592 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
I had just sed in the bug you duped this one to that they are different!

The comment in the MozillaZine Wiki is wrong, but I don't have an account there to fix it.

Bug 254592 ses: if typeaheadfind.autostart is true and typeaheadfind is false, typeahead find should not autostart

This bug ses: if typeaheadfind.autostart is false, typing in the page should not use quick find.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
confirmed, the accessibility.typeaheadfind.autostart pref doesn't seem to have any affect on Quick Find.  The accessibility.typeaheadfind  pref (which is connected to the Options dialog setting) seems to be what controls autostart on and off.  And manual launch of Quick Find with / is not affected by accessibility.typeaheadfind. If that pref is false should you be able to  call Quick Find at all?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Product: Firefox → Toolkit
Still here
Mozilla/5.0 (X11; FreeBSD i386; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
OS: Windows XP → All
Hardware: x86 → All
Duplicate of this bug: 385501
Priority: -- → P5
You need to log in before you can comment on or make changes to this bug.