Floated elements with links in them jumping round the page

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: Mark Brown, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

If I have a series of floating divs with links in them when I click on one of the links the divs jump round the page and change position, widths, heights.. etc.

A fix I have found is to place these divs inside a parent div with the same float.  But we don't want IE displaying the floats better that firefox now do we?

Love Firefox :)


Reproducible: Always

Steps to Reproduce:
<div id=“FirefoxBugfixer” style=“float: left”>
   <div style=“float: left”>Link goes here, Image</div>
   <div style=“float: left”>Link goes here, Image</div>
   <div style=“float: left”>Link goes here, Image</div>
</div>


Expected Results:  
Not changed position just follow the link

Comment 1

12 years ago
can you upload a testcase?

Comment 2

12 years ago
testcase is @ http://www.swinburne.edu.au/ict/testimonials/index_test.html

It works fine for me with the latest BonEcho nightlies on Windows and GNU/Linux, but not on Firefox 1.5.0.6 on Windows.
(Reporter)

Updated

12 years ago
Version: unspecified → 1.5.0.x Branch
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: 1.5.0.x Branch → 1.8 Branch

Comment 3

11 years ago
Created attachment 252452 [details]
Simplified testcase

I confirm this bug, in Firefox 2.0.0.1 on Win32. The attached test case is as simplified as possible.

Comment 4

11 years ago
Confirmed as still a problem in Firefox 2.0.0.3 on Win32.

Comment 5

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007072605 Minefield/3.0a7pre

"Simplified testcase" worksforme on winXP with latest trunk (Firefox3).

Comment 6

10 years ago
"Simplified testcase" works for me too on Firefox3.0b3 - great work, guys.

I suggest this bug be closed as work elsewhere has presumably resulted in the problem going away now.

(btw. 3.0b3 definitely feels faster and less memory-problematic than 2.x - well done.)

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.