mrmq.dk - page not rendered properly

RESOLVED INVALID

Status

()

Core
Layout: Tables
RESOLVED INVALID
12 years ago
9 years ago

People

(Reporter: David Awerbuch, Unassigned)

Tracking

({testcase})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: WONTFIX?, URL)

Attachments

(3 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

Here is a page that does not display the same in FF 1.5.0.6 as it does in IE 6.

http://mrmq.dk/index.htm?page1.htm

The colored lines should be indented, left justified, but not centered as they are by FF.

other problems with other pages, but I bet fixing this will fix many others.

Reproducible: Always

Steps to Reproduce:
1. enter the URL in the address bar

Actual Results:  
lines are centered

Expected Results:  
lines should be left-justified, though indented

Comment 1

12 years ago
I do not see any coloured lines; the only thing that looks anything near that is a <hr>.

It would help a lot if you could attach a small testcase that clearly shows the difference, or a screenshot or two.

Comment 2

12 years ago
Created attachment 233295 [details]
ie6 screenshot

how this webpage look's a IE 6

Comment 3

12 years ago
Created attachment 233296 [details]
Fx 1.5.0.6 screenshot

how this webpage look's at Fx 1.5.0.6

actualy i think it just a rendering broblem here, i havent saw any bug here, sorry

Comment 4

12 years ago
The dotted underline on the links on the left is due to the use of <acronym> (You can just use <a title=""> instead, should work on both browsers).

The <hr> can be fixed by setting border instead: <hr style="border: 1px solid red;">  (This also works fine in IE)
Assignee: nobody → english-other
Component: General → English Other
Product: Firefox → Tech Evangelism
QA Contact: general → english-other
(Reporter)

Comment 5

12 years ago
My sincerest apologies.  I did not realize the site displays unbordered frames, and so I included the wrong URL.. The URL you should be looking at is http://mrmq.dk/channels.htm.  Nore the lines:

    ** --------------------------------------
    ** Minimal XMITQ definition...
    def ql (QMGR.XMITQ1) +
    replace +
    usage (xmitq) +
    ** --------------------------------------
    ** Added for triggering of channels...
    initq (SYSTEM.CHANNEL.INITQ) +
    process (QMGR.XMITQ) +
    trigger +
    trigtype (first)

In FF, these appear to be centered; but in IE they are left justified within their borders, which is what they should be since they are command input to a utility program.

Comment 6

12 years ago
Thanks :)

So, it looks like IE somehow manages to construct a table when no <td> is supplied (see testcase, quirks mode).  Firefox moves everything out of the table instead.

Comment 7

12 years ago
Created attachment 233573 [details]
testcase (quirks, totally invalid html)
Making the summary conform to TE guidelines.
Summary: page not rendered properly → mrmq.dk - page not rendered properly

Comment 9

10 years ago
I'm unclear as to why this is a TE bug; comment 7 makes it sound like the quirks-mode renderer in Gecko should behave differently, and that's Core:Layout.

Someone should definitely tell the site it's using busted HTML, but I don't think it's something we should concern TE with overmuch.

I'm going to kick this to Core:Layout for triage based on comment 6 and 7.
Assignee: english-other → nobody
Component: English Other → Layout
OS: Windows XP → All
Product: Tech Evangelism → Core
QA Contact: english-other → layout
Hardware: PC → All
(Reporter)

Comment 10

10 years ago
It has been close to 2 years since I reported this issue.  Does anyone think this is a serious rendering issue that should be addressed, and probably should have been addressed already?  When the media complains about the support for open-source products, and why companies do not want to consider them, this would be a shining example of the lack of commitment to fixing obvious issues.

Two Years?  Come on, someone must have a clue!  You're a great team - let's see some progress on this.  i will gladly test all corrections for this issue.  Windows XP SP2 is my base.

PS. Has anyone confirmed this issue?  

Comment 11

10 years ago
Hi David,

As Mook said back in 2006, this is a problem with Firefox and IE interpreting certain invalid HTML differently in quirks mode. I'm pretty certain that this will never be changed because as standards-based browsers become more dominant, we've been adding fewer and fewer new quirks, changes to our quirks-mode table handling would probably break many sites that rely on them, more than they fix, and because I doubt anyone wants to add even more complexity to the already confusing table code.

It's possible a developer will see this differently than me so I'll leave it for them to wontfix, but those are my expectations.
Component: Layout → Layout: Tables
QA Contact: layout → layout.tables
Whiteboard: WONTFIX?
(Reporter)

Comment 12

10 years ago
Can someone point to the exact code on the page that is the culprit?  I can point the webmaster to that element and ask them to change it to what is recommended.  Perhaps that will get the problem resolved - you know, using correct code!!
Thanks.  Dave

Comment 13

10 years ago
The exact problem is that there is a <table> and a <tr>, but no <td> to go with them. (Location: first thing in the body, other than a <div> and a <center>.)

Updated

10 years ago
Keywords: testcase

Comment 14

9 years ago
closing as invalid based on comment 13
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.