twisty in header pane (next to email addresses) when there shouldn't be?

RESOLVED FIXED

Status

RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: moco, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

twisty in header pane (next to email addresses) when there shouldn't be?

let me attach a screen shot.
when I saw this, it was happening on many messages, but now, it is not happening anywhere.

could it be related to recent changes mscott and neil made for the header pane recently?
note, I have not been able to reproduce this, but I think a legit bug is lurking...
ok, I think I have a way to reproduce this.

1) select a message in a folder (folder A) with many addresses on the cc line (message X)
2) switch to another folder (folder A) and find a message with one or two cc'd addresses (message Y)
3) switch back to folder A, get the twisty on message X
4) switch back to folder B, the the twisty persists on message Y

Comment 5

13 years ago
 the header pane improvements seem a likely suspect.
(Assignee)

Comment 6

13 years ago
Neil, it looks like I'm not the only one who gets the twisties when they shouldn't be there :)
Sorry, but I can't seem to reproduce this...

* Does it only occur when switching folders?
* Do you need "remember the last selected message"?
* Do you need to expand the twisty on the message that is supposed to have it?
* Does the twisty disappear if you resize the window?
* Is there anything else I have forgotten?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060824 SeaMonkey/1.5a

I confirm seeing this in SeaMonkey trunk, every day for a few weeks now.  
It just about gave me a heart attack.  I sent a very confidential email to 
one person, and checked the email in the Sent folder to make SURE that I 
only sent it to that one person.  When I saw the twisty, I just about died.

If I click on that [+], it changes into [-] but the rest of the display
line doesn't change.  

There used to be a problem where the header pane was sometimes much taller 
than it needed to be, with many blank lines in it.  This occurred when the 
twisty showed [+], and bonking the twisty twice fixed it.  I haven't seen
that problem for a few weeks now, and I wonder if the new twisty behavior 
is a side effect of the fix for that problem.

Comment 9

13 years ago
yes, I think it is a side-effect of that or related changes...

Comment 10

13 years ago
*** Bug 353637 has been marked as a duplicate of this bug. ***
(SeaMonkey) bug 355662 and bug 366825 could be related to this one...

Comment 12

12 years ago
And SeaMonkey bug 369572 (probably a dupe). Seems like we need another MailNews component under Core (but I'm not the right person to report that)...
I hit this ~100% of the time at work.  I'll see if I can figure out steps to repro with a clean profile.
OS: Windows XP → All
Hardware: PC → All
(Assignee)

Comment 14

12 years ago
Chris, have you had any luck poking at this? I've been noticing it too.
Nope.  I didn't get around to trying a clean profile though.
Duplicate of this bug: 378374

Comment 17

12 years ago
Perhaps part of the problem is that in mailWidgets.xml, the method clearEmailAddresses does not remove the twisty--it only changes it to +.  Adding this line seems to fix it:

this.toggleIcon.collapsed = true;

Updated

12 years ago
Duplicate of this bug: 381694
I tried Rod's suggested fix from comment 17, and it did seem to fix this.
(Assignee)

Comment 20

12 years ago
Posted patch the fixSplinter Review
based on Rod's comment 17 and Nelson's verification of Rod's fix.
Attachment #265847 - Flags: review?(neil)
Duplicate of this bug: 382159
Comment on attachment 265847 [details] [diff] [review]
the fix

I can't actually reproduce this bug as described. The only bug I can reproduce is that switching folders to a message that should show the twisty doesn't then display it.

The one thing I was worried about was that the twisty would not show up when it used to. That at least is not the case, so I feel I can still r+ this even though I notice no effect at all!
Attachment #265847 - Flags: review?(neil) → review+
(Assignee)

Comment 23

12 years ago
fixed on the trunk. Thanks so much for the patch Rod! 

Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Assignee)

Comment 24

12 years ago
Comment on attachment 265847 [details] [diff] [review]
the fix

nominating for tbird 2.0.0.5. This is a mailnews only fix and doesn't effect firefox.
Attachment #265847 - Flags: approval1.8.1.5?
Comment on attachment 265847 [details] [diff] [review]
the fix

approved for 1.8.1.5, a=dveditz for release-drivers
Attachment #265847 - Flags: approval1.8.1.5? → approval1.8.1.5+
(Assignee)

Updated

12 years ago
Keywords: fixed1.8.1.5

Comment 26

12 years ago
This bug is still visible in version 2.0.0.5pre (20070628).
i still see this bug in the 2.0.0.5 Release Candidate on Windows Vista, i have the same like in seths screenshot, comment #1
This bug is still visible in 2005rc1 (2007071611) on both Windows XP SP2 and Ubuntu 7.04.  However, it is very sporadic.  Sometimes I get the twisty, sometimes I do not.  In fact, I can click on an email and see the twisty, then come back to that email later and the twisty will be gone, then come back to the email even later and the twisty will be back again.
I see this as well on the Intel Mac RC2, version 2.0.0.5 (20070716). My STR were simply to send an email with 2 cc's on the list. Subsequent attempts to try to reproduce with same steps did not work. And when I went back to the original message the twisty was gone.
removing the fixed1.8.1.5 keyword since this is not fixed in 1.8.1.5 RC 1 Build, see comment #26 - #29
Keywords: fixed1.8.1.5

Comment 31

12 years ago
This problem still appears in the 2.0.0.6 (Windows/20070728) release, but different. I have a couple of e-mails with long c/c lists back-to-back in the Inbox (on IMAP server), with one having just two entries in the c/c inbetween. Walking mail to mail using the cursor keys, or directly left-clicking on the mails, the twisty shows up correctly at the first long-c/c e-mail, then disappears for the next one with a c/c list of identical length. The e-mail with a short or long c/c list shows the twisty again. Thus, the issue only seem to appear with lists of equal length. This is reproducible after restarting Thunderbird.

Also noticed occasional reappearances of the twisty in To or Cc lists which are short enough to display all addresses in a single line (less frequently than before 2.0.0.5, don't notice any reproducible pattern).
Depends on: 355893
You need to log in before you can comment on or make changes to this bug.