Extension manager spams the error console unmercifully

RESOLVED DUPLICATE of bug 314613

Status

()

Toolkit
Add-ons Manager
RESOLVED DUPLICATE of bug 314613
12 years ago
10 years ago

People

(Reporter: bz, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Even though I have extensions.logging.enabled set to false, courtesy of the LOG() function in nsExtensionManager.js.in my Error console contains the following gems:

-------------------------------------------------------------

Datasource: Update Started
Datasource: Addon Update Started: inspector@mozilla.org
Datasource: Addon Update Ended: inspector@mozilla.org, status: 32
Datasource: Addon Update Started: {cf2812dc-6a7c-4402-b639-4d277dac4c36}
RDFItemUpdater:checkForUpdates sending a request to server for: https://addons.mozilla.org/update/VersionCheck.php?reqVersion=1&id={cf2812dc-6a7c-4402-b639-4d277dac4c36}&version=0.6&maxAppVersion=3.0a1&status=%ITEM_STATUS%&appID={ec8030f7-c20a-464f-9b0e-13a3a9e97384}&appVersion=3.0a1&appOS=Linux&appABI=x86-gcc3, item = ({id:"{cf2812dc-6a7c-4402-b639-4d277dac4c36}", version:"0.6", installLocationKey:"app-global", minAppVersion:"3.0a1", maxAppVersion:"3.0a1", name:"Mozilla XForms", xpiURL:"none", xpiHash:"", iconURL:"chrome://mozapps/skin/xpinstall/xpinstallItemGeneric.png", updateRDF:"", type:2})
RDFItemUpdater:onDatasourceLoaded: Datasource empty.

If you are an Extension developer and were expecting there to be

updates, this could mean any number of things, since the RDF system

doesn't give up much in the way of information when the load fails.



Try checking that: 

 1. Your remote RDF file exists at the location.

 2. Your RDF file is valid XML (starts with <?xml version="1.0?">

    and loads in Firefox displaying pretty printed like other XML documents

 3. Your server is sending the data in the correct MIME

    type (text/xml)

-------------------------------------------------------------
and so on, for about 30 more items.  Please, for the sake of sanity of us all, make all this obey the pref.

*** This bug has been marked as a duplicate of 314613 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.