When customizing the url bar drop down is active

RESOLVED FIXED

Status

()

--
minor
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: mossop, Assigned: mossop)

Tracking

({fixed1.8.1, regression})

2.0 Branch
x86
Windows XP
fixed1.8.1, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Assignee)

Description

13 years ago
If you start customizing toolbars then the url bar will still have an active drop down arrow. Moving the mouse over the url bar does not show a grab cursor but a standard pointer though dragging is possible at this point. This is a regression from bug 337427.

This only occurs on the 1.8 branch.
(Assignee)

Comment 1

13 years ago
Created attachment 233356 [details] [diff] [review]
patch rev 1

The problem appears to be caused by the use of a deck in the url bar. Switching to a hbox for instance makes this problem go away but I don't see a way of achieving what bug 337427 was after without it.

Instead this patch is just a bit of a CSS hack to ensure the cursor is correct and to hide the active drop arrow when customizing.

I have tentatively included the same rules for pinstripe but I have no access to a Mac and so do not know if the problem occurs there,
Assignee: nobody → mossop.bugzilla
Status: NEW → ASSIGNED
Attachment #233356 - Flags: review?(mconnor)
(Assignee)

Comment 2

13 years ago
Created attachment 233390 [details] [diff] [review]
branch patch

Since the branch and trunk are somewhat different right now and this issue can only be seen on branch builds this is a patch that applies to branch.

Otherwise this is an identical patch.
Comment on attachment 233390 [details] [diff] [review]
branch patch

r+a=me for this branch only theme patch
Attachment #233390 - Flags: review+
Attachment #233390 - Flags: approval1.8.1+
Whiteboard: [checkin needed (1.8 branch)]
(Assignee)

Comment 4

13 years ago
Fixed on 1.8 branch only.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
Whiteboard: [checkin needed (1.8 branch)]
(Assignee)

Updated

13 years ago
Attachment #233356 - Flags: review?(mconnor)

Updated

13 years ago
Depends on: 348946
Created attachment 234140 [details]
screen shot

I think that 'display: none' is more better than 'visibility: hidden'.
You need to log in before you can comment on or make changes to this bug.