File --> Print & Crash

RESOLVED WORKSFORME

Status

()

Core
Printing: Output
--
critical
RESOLVED WORKSFORME
12 years ago
4 years ago

People

(Reporter: dan, Unassigned)

Tracking

({crash})

1.8 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1

When going to File --> Print, Firefox should automatically select the default printer in the menu box. If not, then it has a chance of crashing all the time.

Eg. I added a network printer located on //main/HP main (thats the name with main replacing where it was located). When computer 'main' is offline, the printer can not be accessed.

Going to start --> settings --> printers & Faxes --> and seeing all printers, the //main/HP main shows up as being offline. Right clicking on the printer and selecting properties or most of the options will return an error since the computer is down.

Thus, when Firefox selects the printer that was last used instead of the default printer, in my case, the computer was down, and firefox froze. 

This problem can be repeated with printer down, and reopening firefox.

Of course, if I add the printer through HP software as a different type, with a different address it will not crash.

Reproducible: Always

Steps to Reproduce:
1. add network printer through start --> settings --> printers & faxes 
2. turn computer off, leaving printer on or off doesn't matter
3. tell firefox to print to that printer, it will freeze, and the next time you select print, on selection from file menu it will freeze since it will be loaded automatically.

Actual Results:  
Crash.

Expected Results:  
Crash.

Said printer was not available or offline. OR on selection of print go to default printer. OR have option in  Tools --> options to pick default each time or pick last printer.
(Reporter)

Comment 1

12 years ago
the last paragraph I wrote is what firefox should do

Comment 2

12 years ago
Please get a Talkback ID for the crash. http://kb.mozillazine.org/Talkback
Severity: major → critical
Keywords: crash
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060812 BonEcho/2.0b1 ID:2006081205

WFM if i set any printer installed on my system (e.g. adobe pdf, fineprint, fax printer) manually offline and then try to print using these. windows puts the print tasks in a offline queue.
don't know if these steps trying to reproduce match OP's case though

Comment 4

12 years ago
presumably this is an hp printer driver (you should perhaps include the full printer driver details in your next comment). as such, this is a duplicate.

we're sorry. there is a bug describing how to fix it, but I'm under-resourced, so I haven't fixed it.

note that the bug is first and foremost a bug in the printer driver, and complaints to HP or whichever vendor it is are appreciated. They shouldn't be crashing poor unfortunate cute little apps like gecko.
Assignee: nobody → printing
Component: General → Printing
Product: Firefox → Core
QA Contact: general
Whiteboard: DUPME
Version: unspecified → 1.8 Branch

Updated

12 years ago
Whiteboard: DUPME → DUPEME
works for me on Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a6pre) Gecko/20070612 Minefield/3.0a6pre ID:2007061212 [cairo] with a HP Deskjet Printer as Printer.

Dan, do you still crash with a latest release and HP Driver ?
(Reporter)

Comment 6

11 years ago
HP recently released a new update to their software package. Not sure if that did anything, but I haven't had any problems related to that. I am using hp photosmart 2610.

although, a couple days before the update I canceled a print and was told that the printing failed. clicking on ok would result in the same popup, even after closing that window, closing all firefox internet windows (leaving the download box open). closed everything and restarted firefox and it seemed to work. Not really sure what was happening there.

but the point is, this bug should be closed unless anyone has any objections.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Dan, many thanks for your feedback.


changine to works for me since fixed mean that a code change happend (like a Patch).
Resolution: FIXED → WORKSFORME

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.