Status

()

Core
Layout
P2
normal
VERIFIED DUPLICATE of bug 3180
20 years ago
19 years ago

People

(Reporter: troy, Assigned: buster)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
NTDLL! 77f76148()
nsDebug::Assertion(const char * 0x00677d9c, const char * 0x00677d94, const char
* 0x00677d5c, int 421) line 140 + 13 bytes
nsContainerFrame::DeleteChildsNextInFlow(nsIPresContext & {...}, nsIFrame *
0x01739140) line 421 + 32 bytes
nsContainerFrame::DeleteChildsNextInFlow(nsIPresContext & {...}, nsIFrame *
0x01712270) line 417
nsBlockReflowContext::ReflowBlock(nsIFrame * 0x01712270, const nsRect & {x=0 y=0
width=3397 height=1073741824}, int 0, nsMargin & {top=0 right=0 bottom=0
left=0}, unsigned int & 0) line 215
nsInlineFrame::ReflowBlockFrame(nsIPresContext & {...}, const nsHTMLReflowState
& {...}, nsInlineFrame::InlineReflowState & {...}, nsHTMLReflowMetrics & {...},
unsigned int & 0) line 1685 + 40 bytes
nsInlineFrame::Reflow(nsInlineFrame * const 0x01780834, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 1216 + 31 bytes
nsInlineReflow::ReflowFrame(nsIFrame * 0x01780830, int 1, unsigned int & 0) line
311
nsBlockFrame::ReflowInlineFrame(nsBlockReflowState & {...}, nsLineBox *
0x017807c0, nsIFrame * 0x01780830, int * 0x00127648) line 2668 + 28 bytes
nsBlockFrame::ReflowLine(nsBlockReflowState & {...}, nsLineBox * 0x017807c0, int
* 0x001276b0) line 1837 + 24 bytes
nsBlockFrame::ReflowDirtyLines(nsBlockReflowState & {...}) line 1585 + 20 bytes
nsBlockFrame::Reflow(nsBlockFrame * const 0x0170d2d4, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 995 + 18 bytes
nsAreaFrame::Reflow(nsAreaFrame * const 0x0170d2d4, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 509 + 28 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x0170d2d0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 364 + 28 bytes
nsTableCellFrame::Reflow(nsTableCellFrame * const 0x0170d374, nsIPresContext &
{...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned
int & 0) line 483
nsContainerFrame::ReflowChild(nsIFrame * 0x0170d370, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 364 + 28 bytes
nsTableRowFrame::ResizeReflow(nsTableRowFrame * const 0x0170d770, nsIPresContext
& {...}, nsHTMLReflowMetrics & {...}, RowReflowState & {...}, unsigned int & 0)
line 616 + 37 bytes
nsTableRowFrame::Reflow(nsTableRowFrame * const 0x0170d774, nsIPresContext &
{...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned
int & 0) line 1435 + 35 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x0170d770, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 364 + 28 bytes
nsTableRowGroupFrame::ReflowMappedChildren(nsTableRowGroupFrame * const
0x0170db40, nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
RowGroupReflowState & {...}, unsigned int & 0, nsTableRowFrame * 0x00000000,
nsReflowReason eReflowReason_Resize, int 1) line 420 + 34 bytes
nsTableRowGroupFrame::Reflow(nsTableRowGroupFrame * const 0x0170db44,
nsIPresContext & {...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState &
{...}, unsigned int & 0) line 949 + 39 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x0170db40, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 364 + 28 bytes
nsTableFrame::ReflowMappedChildren(nsTableFrame * const 0x0170c190,
nsIPresContext & {...}, nsHTMLReflowMetrics & {...}, InnerTableReflowState &
{...}, unsigned int & 0) line 3564 + 31 bytes
nsTableFrame::ResizeReflowPass2(nsTableFrame * const 0x0170c190, nsIPresContext
& {...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned
int & 0) line 2687 + 31 bytes
nsTableFrame::Reflow(nsTableFrame * const 0x0170c194, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 2501 + 38 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x0170c190, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 364 + 28 bytes
nsTableOuterFrame::Reflow(nsTableOuterFrame * const 0x0170c294, nsIPresContext &
{...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned
int & 0) line 958 + 37 bytes
nsBlockReflowContext::ReflowBlock(nsIFrame * 0x0170c290, const nsRect & {x=0
y=285 width=3547 height=1073741824}, int 0, nsMargin & {top=0 right=0 bottom=0
left=0}, unsigned int & 0) line 146 + 42 bytes
nsBlockFrame::ReflowBlockFrame(nsBlockReflowState & {...}, nsLineBox *
0x01714a90, int * 0x0012937c) line 2478 + 45 bytes
nsBlockFrame::ReflowLine(nsBlockReflowState & {...}, nsLineBox * 0x01714a90, int
* 0x0012937c) line 1802 + 20 bytes
nsBlockFrame::ReflowDirtyLines(nsBlockReflowState & {...}) line 1585 + 20 bytes
nsBlockFrame::Reflow(nsBlockFrame * const 0x0170ac84, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 995 + 18 bytes
nsBlockReflowContext::ReflowBlock(nsIFrame * 0x0170ac80, const nsRect & {x=0 y=0
width=3547 height=1073741824}, int 1, nsMargin & {top=0 right=0 bottom=0
left=0}, unsigned int & 0) line 146 + 42 bytes
nsBlockFrame::ReflowBlockFrame(nsBlockReflowState & {...}, nsLineBox *
0x017144e0, int * 0x0012a134) line 2478 + 45 bytes
nsBlockFrame::ReflowLine(nsBlockReflowState & {...}, nsLineBox * 0x017144e0, int
* 0x0012a134) line 1802 + 20 bytes
nsBlockFrame::ReflowDirtyLines(nsBlockReflowState & {...}) line 1585 + 20 bytes
nsBlockFrame::Reflow(nsBlockFrame * const 0x0173a514, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 995 + 18 bytes
nsAreaFrame::Reflow(nsAreaFrame * const 0x0173a514, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 509 + 28 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x0173a510, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 364 + 28 bytes
nsTableCellFrame::Reflow(nsTableCellFrame * const 0x0173a5b4, nsIPresContext &
{...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned
int & 0) line 483
nsContainerFrame::ReflowChild(nsIFrame * 0x0173a5b0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 364 + 28 bytes
nsTableRowFrame::ResizeReflow(nsTableRowFrame * const 0x0173a6c0, nsIPresContext
& {...}, nsHTMLReflowMetrics & {...}, RowReflowState & {...}, unsigned int & 0)
line 616 + 37 bytes
nsTableRowFrame::Reflow(nsTableRowFrame * const 0x0173a6c4, nsIPresContext &
{...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned
int & 0) line 1435 + 35 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x0173a6c0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 364 + 28 bytes
nsTableRowGroupFrame::ReflowMappedChildren(nsTableRowGroupFrame * const
0x01788d80, nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
RowGroupReflowState & {...}, unsigned int & 0, nsTableRowFrame * 0x00000000,
nsReflowReason eReflowReason_Resize, int 1) line 420 + 34 bytes
nsTableRowGroupFrame::Reflow(nsTableRowGroupFrame * const 0x01788d84,
nsIPresContext & {...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState &
{...}, unsigned int & 0) line 949 + 39 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x01788d80, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 364 + 28 bytes
nsTableFrame::ReflowMappedChildren(nsTableFrame * const 0x01788bf0,
nsIPresContext & {...}, nsHTMLReflowMetrics & {...}, InnerTableReflowState &
{...}, unsigned int & 0) line 3564 + 31 bytes
nsTableFrame::ResizeReflowPass2(nsTableFrame * const 0x01788bf0, nsIPresContext
& {...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned
int & 0) line 2687 + 31 bytes
nsTableFrame::Reflow(nsTableFrame * const 0x01788bf4, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 2501 + 38 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x01788bf0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 364 + 28 bytes
nsTableOuterFrame::Reflow(nsTableOuterFrame * const 0x01788cf4, nsIPresContext &
{...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned
int & 0) line 958 + 37 bytes
nsBlockReflowContext::ReflowBlock(nsIFrame * 0x01788cf0, const nsRect & {x=0 y=0
width=10560 height=14400}, int 1, nsMargin & {top=0 right=0 bottom=0 left=0},
unsigned int & 0) line 146 + 42 bytes
nsBlockFrame::ReflowBlockFrame(nsBlockReflowState & {...}, nsLineBox *
0x017888e0, int * 0x0012be00) line 2478 + 45 bytes
nsBlockFrame::ReflowLine(nsBlockReflowState & {...}, nsLineBox * 0x017888e0, int
* 0x0012be00) line 1802 + 20 bytes
nsBlockFrame::ReflowDirtyLines(nsBlockReflowState & {...}) line 1585 + 20 bytes
nsBlockFrame::Reflow(nsBlockFrame * const 0x01788854, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 1)
line 995 + 18 bytes
nsBlockReflowContext::ReflowBlock(nsIFrame * 0x01788850, const nsRect & {x=0 y=0
width=10560 height=14400}, int 1, nsMargin & {top=0 right=0 bottom=0 left=0},
unsigned int & 1) line 146 + 42 bytes
nsBlockFrame::ReflowBlockFrame(nsBlockReflowState & {...}, nsLineBox *
0x017887e0, int * 0x0012cbb8) line 2478 + 45 bytes
nsBlockFrame::ReflowLine(nsBlockReflowState & {...}, nsLineBox * 0x017887e0, int
* 0x0012cbb8) line 1802 + 20 bytes
nsBlockFrame::ReflowDirtyLines(nsBlockReflowState & {...}) line 1585 + 20 bytes
nsBlockFrame::Reflow(nsBlockFrame * const 0x01788754, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 1)
line 995 + 18 bytes
nsBlockReflowContext::ReflowBlock(nsIFrame * 0x01788750, const nsRect & {x=0 y=0
width=10560 height=14400}, int 1, nsMargin & {top=0 right=0 bottom=0 left=0},
unsigned int & 1) line 146 + 42 bytes
nsBlockFrame::ReflowBlockFrame(nsBlockReflowState & {...}, nsLineBox *
0x017886e0, int * 0x0012d970) line 2478 + 45 bytes
nsBlockFrame::ReflowLine(nsBlockReflowState & {...}, nsLineBox * 0x017886e0, int
* 0x0012d970) line 1802 + 20 bytes
nsBlockFrame::ReflowDirtyLines(nsBlockReflowState & {...}) line 1585 + 20 bytes
nsBlockFrame::Reflow(nsBlockFrame * const 0x01788654, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 1)
line 995 + 18 bytes
nsBlockReflowContext::ReflowBlock(nsIFrame * 0x01788650, const nsRect & {x=0 y=0
width=10800 height=14400}, int 1, nsMargin & {top=0 right=0 bottom=0 left=0},
unsigned int & 1) line 146 + 42 bytes
nsBlockFrame::ReflowBlockFrame(nsBlockReflowState & {...}, nsLineBox *
0x017885e0, int * 0x0012e728) line 2478 + 45 bytes
nsBlockFrame::ReflowLine(nsBlockReflowState & {...}, nsLineBox * 0x017885e0, int
* 0x0012e728) line 1802 + 20 bytes
nsBlockFrame::ReflowDirtyLines(nsBlockReflowState & {...}) line 1585 + 20 bytes
nsBlockFrame::Reflow(nsBlockFrame * const 0x017883f4, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 995 + 18 bytes
nsAreaFrame::Reflow(nsAreaFrame * const 0x017883f4, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 509 + 28 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x017883f0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 364 + 28 bytes
nsPageFrame::Reflow(nsPageFrame * const 0x01788574, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 112
nsContainerFrame::ReflowChild(nsIFrame * 0x01788570, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 364 + 28 bytes
nsSimplePageSequenceFrame::Reflow(nsSimplePageSequenceFrame * const 0x0163c2f4,
nsIPresContext & {...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState &
{...}, unsigned int & 0) line 140
nsContainerFrame::ReflowChild(nsIFrame * 0x0163c2f0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 364 + 28 bytes
nsScrollFrame::Reflow(nsScrollFrame * const 0x0163c794, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 362
nsContainerFrame::ReflowChild(nsIFrame * 0x0163c790, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 364 + 28 bytes
ViewportFrame::Reflow(ViewportFrame * const 0x0163e3f4, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 434
PresShell::InitialReflow(PresShell * const 0x016398b0, int 8820, int 5250) line
857
DocumentViewerImpl::Init(DocumentViewerImpl * const 0x0163abb0, void *
0x00340224, nsIDeviceContext * 0x0160a5d0, nsIPref * 0x00ebe780, const nsRect &
{x=0 y=0 width=588 height=350}, nsScrollPreference nsScrollPreference_kAuto)
line 360
nsWebShell::Embed(nsWebShell * const 0x0164c240, nsIContentViewer * 0x0163abb0,
const char * 0x00416974, nsISupports * 0x00000000) line 664 + 69 bytes
nsBrowserWindow::Init(nsIAppShell * 0x00ebe800, nsIPref * 0x00ebe780, const
nsRect & {x=0 y=0 width=600 height=400}, unsigned int 8, int 1,
nsIDocumentViewer * 0x00f4bad0, nsIPresContext * 0x0164c940) line 1087
nsBrowserWindow::ShowPrintPreview(int 40050) line 1839
nsBrowserWindow::DispatchMenuItem(int 40050) line 480
nsNativeBrowserWindow::DispatchMenuItem(int 40050) line 92
HandleBrowserEvent(nsGUIEvent * 0x0012fea4) line 313 + 18 bytes
nsWindow::DispatchEvent(nsWindow * const 0x00f08e00, nsGUIEvent * 0x0012fea4,
nsEventStatus & nsEventStatus_eIgnore) line 378 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012fea4) line 394
nsWindow::ProcessMessage(unsigned int 273, unsigned int 40050, long 0, long *
0x0012fef4) line 1602 + 21 bytes
nsWindow::WindowProc(HWND__ * 0x005a00cc, unsigned int 273, unsigned int 40050,
long 0) line 437 + 27 bytes
USER32! 77e71250()
(Reporter)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 1

20 years ago
This looks very similar, so I'm marking it as a DUP of # 3180. Some additional
info is that the frame whose next-in-flow we're deleting is an anonymous block
frame

*** This bug has been marked as a duplicate of 3180 ***
(Reporter)

Comment 2

20 years ago
Note that this page crashes when bringing up the print preview window, and not
when closing it

Updated

19 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.