All users were logged out of Bugzilla on October 13th, 2018

MLK: Memory leak from BritishAirways.com - possibly in JavaScript

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
12 years ago
12 years ago

People

(Reporter: mike.fleetwood, Unassigned)

Tracking

({memory-leak})

Trunk
x86
All
memory-leak
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1

The BritishAirways.com web site causes Firefox to use ~30% CPU and memory to grow without bound.  Freshly started Firefox process.  Virtual memory size was 139 MiB.  20 minutes later after doing nothing the virtual memory size had grown to 1095 MiB.  That's ~39 MiB leak per minute.


Reproducible: Always

Steps to Reproduce:
1. Go to the BritishAirways.com web site
2. Monitor Firefox process memory size (e.g. via top)

Actual Results:  
Firefox process size grows without bound.


Fedora Core 5 (x86) OS with all updates.
Also effects Firefox 1.5.0.4 and 1.5.0.6 Fedora packages the same way.

This may no technically be a memory leak as the resident set size of Firefox also grows to as much as the OS can handle.  This suggests that the process is accessing all the pages in its virtual memory.

When I first discovered this problem a few days ago Firefox (then 1.5.0.4) had been left for several hours.  The virtual memory size grew to 1819 MiB and was causing the machine to swap so much that the CPU was spending 95% of its time waiting for disk IO completion.  Heres the output from top:

top - 20:04:02 up 3 days, 32 min,  3 users,  load average: 7.19, 7.61, 5.12
Tasks: 116 total,   2 running, 114 sleeping,   0 stopped,   0 zombie
Cpu(s):  0.9% us,  3.8% sy,  0.0% ni,  0.0% id, 94.8% wa,  0.4% hi,  0.0% si,  0Mem:   1035168k total,  1021516k used,    13652k free,      272k buffers
Swap:  1004052k total,  1004040k used,       12k free,     9056k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
  171 root      15   0     0    0    0 D  3.3  0.0   0:14.52 kswapd0
 2226 haldaemo  15   0  5100 1056  708 S  0.3  0.1   0:01.79 hald
10592 root      15   0  213m 3760 1048 S  0.3  0.4   7:46.14 Xorg
10692 mike      15   0 21272 1152  916 S  0.3  0.1   0:01.31 gnome-volume-ma
12008 mike      16   0 1819m 924m  876 D  0.3 91.5 145:36.94 firefox-bin
18691 mike      15   0  2128  644  428 R  0.3  0.1   0:00.54 top
    1 root      16   0  2000  276  248 S  0.0  0.0   0:00.82 init

Comment 1

12 years ago
This appears to be happening on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060812 BonEcho/2.0b1 too.
OS: Linux → All

Comment 2

12 years ago
The leak monitor extension does not pick up on where the ram usage is coming from.

Comment 3

12 years ago
Trunk issue too - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060810 Minefield/3.0a1
Version: unspecified → Trunk

Comment 4

12 years ago
We're probably going to have to use some more-advanced leak logging tools to track this down; e.g. leak guage or trace refcount logs.
Keywords: mlk
WORKSFORME with SeaMonkey 2006083109-trunk/Win-2K.
(No extension other than LiveHTTPHeaders)
"Virtual Memory Size" value for SeaMonky by Task Manager on Win-2K stays constant after load completes.

To Mike Fleetwood(bug opener) and Kevin Brosnan :
(Q1) Do you use extensions?
     Problem can be re-created with -safe-mode?
     Problem can be re-created with new profile?
     ( See Bug 320915 Comment #24 for difference between -safe-mode and )
     ( new profile when Adbblock's severe memory leak in tha past.      )
(Reporter)

Comment 6

12 years ago
Extensions?
Firefox 1.5.0.6, in Linux Fedora Core 5, came with these extensions:
DOM Inspector 1.8.0.6 and lots of Languate Packs 1.5.0.6.  I have also
installed Session Manager 0.4.2.

Firefox 2.0b1 reported these extensions: DOM Inspector 1.8.1b1, Talkback 2.0b1
and Session Manager 0.4.2, which was disabled because it was not compatible.

I can no longer re-create the problem with Firefox 1.5.0.6 or 2.0b1.  In
the mean time I have contiuned to apply all Fedora Core 5 OS updates,
however since Kevin Brosnan confirmed the issue on Windows NT 5.1 (XP?)
the common factor is Firefox.  My best guess is that BritishAirways changed
their web site so the problem is no longer triggered.  Also tried with
Firefox 1.5.0.7 and 2.0b2, still no memory leak.

Thanks,
Mike

Comment 7

12 years ago
This works for me now on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20070116 Minefield/3.0a2pre ID:2007011604 [cairo]

Comment 8

12 years ago
per the last two comments including the reporter... WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
v. also no alarm from the leak monitor extension on this site
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.