Search bar drag and drop should apply to the search button only (and not the text field)

RESOLVED INVALID

Status

()

--
minor
RESOLVED INVALID
12 years ago
3 years ago

People

(Reporter: me, Unassigned)

Tracking

({helpwanted})

Trunk
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060813 BonEcho/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060813 BonEcho/2.0b1

Currently, dragging and dropping text to the search bar's text area will immediately search the text dropped there using the selected search engine.  IMHO, dragging and dropping text onto the search button (magnifying glass) should initiate a search for the text dropped there, but dragging text to the search bar's text area should just display the text there.

This applies for Bon Echo and Minefield, but not for older versions as there is no "search button".

Reproducible: Always
(Reporter)

Updated

12 years ago
OS: Windows XP → All
Hardware: PC → All
Seems very uncomfortable to me. Not only because your movements need to be more precise (button surface is smaller) but also because not all people have the search button on their toolbar. In that case you always need to do an extra click.
People have already the possibility to drag a search term to the location bar, in which case they can edit the text first before clicking Go. It will do a search according to the keyword.URL.

I thought I saw this bug before so possibly this is a dupe. 
 
I don't agree. There isn't much harm in searching immediately, and as Ria said, having to hit the button just makes the drop target smaller.
Severity: enhancement → minor
Summary: Dragging and dropping text to search button should search the text → Search bar drag and drop should apply to the search button only (and not the text field)
Version: unspecified → Trunk
(Reporter)

Comment 3

12 years ago
Perhaps an user would want to "build" a search out of a few keywords, though?  If the user wanted to do a search immediately, they could then drop it on the "search" button.
(Reporter)

Updated

12 years ago
Keywords: helpwanted

Comment 4

9 years ago
This seems to make more sense now that the button is inside the search box.

I frequently want to search for something in a new tab, and the fastest way to do that would be to drag the text to the search box and then middle-click the search button. (Another way would be the ability to middle-click the "Search {default search provider} for '{selected text}'" context menu item.)
With one-off searches implemented, dropping text always adds the text to the search fieldand never runs a search, so this bug doesn't apply anymore.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.