Contents of <iframe> not firing valid accessibility events

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
13 years ago
21 days ago

People

(Reporter: aaronlev, Assigned: aaronlev)

Tracking

(Blocks 1 bug, {access, regression})

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(3 attachments)

Assignee

Description

13 years ago
Steps:
Load a document with an iframe, such as 
http://www.mozilla.org/access/samples/js-nsIAccessible.htm
With an accessibility testing tool open, tab until you get to the iframe contents.

Accessibility events are fired, but the role, state and other info are not available for the event targets.
Assignee

Updated

13 years ago
Assignee: aaronleventhal → nian.liu
Posted file foo.html
aaron, which at event tool you use?

Assignee

Comment 4

13 years ago
(In reply to comment #3)
> aaron, which at event tool you use?

MSAA Inspect will work, or a combination of that and MSAA event watcher. But, I think the same problem would show up if watching the events on Linux using at-poke.
Assignee

Updated

13 years ago
Blocks: htmla11y
No longer blocks: keya11y
Assignee

Comment 5

12 years ago
1-25 works
1-26 broken
Assignee

Comment 6

12 years ago
Sorry, forgot to say the regression was in 2006.

1-25-2006 works
1-26-2006 broken
Assignee

Comment 7

12 years ago
The domNode in PresShell::HandleEventInternal() is for the root html doc instead of the iframe doc. Not sure why yet, because the HWND we use with NotifyWinEvent() is for the correct window.
Assignee: nian.liu → aaronleventhal
Assignee

Comment 9

12 years ago
Robert, this was a regression from your patch to bug 317375.
Attachment #261718 - Flags: superreview?(roc)
Attachment #261718 - Flags: review?(roc)
Assignee

Comment 10

12 years ago
Comment on attachment 261718 [details] [diff] [review]
One line patch for regression. Don't treat NS_ACCESSIBLE_EVENT like a mouse event.

Probably better to get 2 eyes on this given how long ago bug 317375 was checked in, and how complex it was.

I wonder if we need to change any other similar places.
Attachment #261718 - Flags: superreview?(roc) → superreview?(dbaron)
Assignee

Updated

12 years ago
Keywords: regression
OS: All → Windows XP
Attachment #261718 - Flags: superreview?(dbaron)
Attachment #261718 - Flags: superreview+
Attachment #261718 - Flags: review?(roc)
Attachment #261718 - Flags: review+
Assignee

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.